aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-02-05 19:04:33 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2012-02-05 19:04:33 +0000
commitf3410da7f0bd208a5f2d792131b215454e782e93 (patch)
tree6e79c9acde383b91f5f21eb3a72f33e9c7fbbfce /Makefile.in
parent03dfbc2efa31d3c4fd7e576111883ea488e3e179 (diff)
downloadwavemon-f3410da7f0bd208a5f2d792131b215454e782e93.tar.gz
Imported Upstream version 0.7.3upstream/0.7.3
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 7c81ad5..b7d8ece 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -5,6 +5,8 @@ bindir = @bindir@
datarootdir = $(prefix)/share
mandir = @mandir@
datadir = $(datarootdir)/@PACKAGE_NAME@
+exec_perms = 0755
+install-suid-root: exec_perms = 4755
CC = @CC@
CFLAGS = @CFLAGS@
@@ -41,9 +43,9 @@ tags: $(MAIN) $(PURESRC) $(HEADERS)
install: install-binaries install-docs
-install-binaries: all
+install-suid-root install-binaries: all
$(INSTALL) -m 0755 -d $(DESTDIR)$(bindir)
- $(INSTALL) -m 0755 @PACKAGE_NAME@ $(DESTDIR)$(bindir)
+ $(INSTALL) -m $(exec_perms) @PACKAGE_NAME@ $(DESTDIR)$(bindir)
install-docs: @PACKAGE_NAME@.1 @PACKAGE_NAME@rc.5 $(DOCS)
$(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man1