aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-02-05 19:03:25 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2012-02-05 19:03:25 +0000
commit03dfbc2efa31d3c4fd7e576111883ea488e3e179 (patch)
tree6f227b085f675e294edd98d66ccbf190e898f544 /Makefile.in
downloadwavemon-03dfbc2efa31d3c4fd7e576111883ea488e3e179.tar.gz
Imported Upstream version 0.6.10upstream/0.6.10
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in67
1 files changed, 67 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
new file mode 100644
index 0000000..7c81ad5
--- /dev/null
+++ b/Makefile.in
@@ -0,0 +1,67 @@
+prefix = @prefix@
+exec_prefix = @exec_prefix@
+
+bindir = @bindir@
+datarootdir = $(prefix)/share
+mandir = @mandir@
+datadir = $(datarootdir)/@PACKAGE_NAME@
+
+CC = @CC@
+CFLAGS = @CFLAGS@
+DEFS = @DEFS@
+LDLIBS = @LIBS@
+
+INSTALL = @INSTALL@
+RM = rm -vf
+
+MAIN = @PACKAGE_NAME@.c
+HEADERS = @PACKAGE_NAME@.h llist.h iw_if.h
+PURESRC = $(filter-out $(MAIN),$(wildcard *.c))
+OBJS = $(PURESRC:.c=.o)
+DOCS = README NEWS THANKS AUTHORS COPYING ChangeLog
+
+%.o: %.c $(HEADERS)
+ $(CC) $(CFLAGS) $(DEFS) -c -o $@ $<
+
+all: @PACKAGE_NAME@
+@PACKAGE_NAME@: $(MAIN) $(OBJS)
+
+$(MAIN): Makefile
+Makefile: Makefile.in config.status
+ ./config.status
+config.status: configure
+ ./config.status --recheck
+configure: configure.ac
+ autoconf
+
+tags: $(MAIN) $(PURESRC) $(HEADERS)
+ ctags $^ > $@
+
+.PHONY: all install uninstall clean distclean
+
+install: install-binaries install-docs
+
+install-binaries: all
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(bindir)
+ $(INSTALL) -m 0755 @PACKAGE_NAME@ $(DESTDIR)$(bindir)
+
+install-docs: @PACKAGE_NAME@.1 @PACKAGE_NAME@rc.5 $(DOCS)
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 0644 @PACKAGE_NAME@.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man5
+ $(INSTALL) -m 0644 @PACKAGE_NAME@rc.5 $(DESTDIR)$(mandir)/man5
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(datadir)
+ $(INSTALL) -m 0644 $(DOCS) $(DESTDIR)$(datadir)
+
+uninstall:
+ @$(RM) $(bindir)/@PACKAGE_NAME@
+ @$(RM) $(mandir)/man1/@PACKAGE_NAME@.1
+ @$(RM) $(mandir)/man5/@PACKAGE_NAME@rc.5
+ @$(RM) -r $(datadir)
+
+clean:
+ @$(RM) *.o *~ tags @PACKAGE_NAME@
+
+distclean: uninstall clean
+ @$(RM) config.status config.log config.cache Makefile
+ @$(RM) -r autom4te.cache