aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2014-03-23 01:10:54 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2014-03-23 01:12:35 +0000
commit75285b1c7340663b4e9b848b385ea50ebe3eac06 (patch)
treeb7966791e9a811ff218d31a2617f78263d659f52
parent9068001d20353a23d423ae2e770b96300003b50f (diff)
downloadwavemon-75285b1c7340663b4e9b848b385ea50ebe3eac06.tar.gz
Manually install docs using dh (Closes: #736932)
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/01-patch-makefile.in-to-not-install-docs.patch31
-rw-r--r--debian/patches/01-remove-extra-copyright-file.patch18
-rw-r--r--debian/patches/series2
-rw-r--r--debian/wavemon.docs4
5 files changed, 44 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index 7c6ccd7..ec63c6d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+wavemon (0.7.6-2) UNRELEASED; urgency=medium
+
+ * d/patches: Drop 01-remove-extra-copyright-file.patch; replace with
+ 01-patch-makefile.in-to-not-install-docs.patch
+ - Add d/wavemon.docs to manually install docs (Closes: #736932)
+
+ -- Jonathan McCrohan <jmccrohan@gmail.com> Sat, 22 Mar 2014 17:17:45 +0000
+
wavemon (0.7.6-1) unstable; urgency=low
* New upstream release
diff --git a/debian/patches/01-patch-makefile.in-to-not-install-docs.patch b/debian/patches/01-patch-makefile.in-to-not-install-docs.patch
new file mode 100644
index 0000000..e000145
--- /dev/null
+++ b/debian/patches/01-patch-makefile.in-to-not-install-docs.patch
@@ -0,0 +1,31 @@
+From: Jonathan McCrohan <jmccrohan@gmail.com>
+Date: Sun, 23 Mar 2014 01:02:44 +0000
+Subject: Patch Makefile.in to not install docs; install using dh instead
+
+diff --git a/Makefile.in b/Makefile.in
+index 0b27ad7..3cc8acc 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -22,7 +22,6 @@ MAIN = @PACKAGE_NAME@.c
+ HEADERS = @PACKAGE_NAME@.h llist.h iw_if.h
+ PURESRC = $(filter-out $(MAIN),$(wildcard *.c))
+ OBJS = $(PURESRC:.c=.o)
+-DOCS = README NEWS THANKS AUTHORS COPYING ChangeLog
+
+ %.o: %.c $(HEADERS)
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(DEFS) -c -o $@ $<
+@@ -49,13 +48,11 @@ install-suid-root install-binaries: all
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(bindir)
+ $(INSTALL) -m $(exec_perms) @PACKAGE_NAME@ $(DESTDIR)$(bindir)
+
+-install-docs: @PACKAGE_NAME@.1 @PACKAGE_NAME@rc.5 $(DOCS)
++install-docs: @PACKAGE_NAME@.1 @PACKAGE_NAME@rc.5
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 0644 @PACKAGE_NAME@.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man5
+ $(INSTALL) -m 0644 @PACKAGE_NAME@rc.5 $(DESTDIR)$(mandir)/man5
+- $(INSTALL) -m 0755 -d $(DESTDIR)$(datadir)
+- $(INSTALL) -m 0644 $(DOCS) $(DESTDIR)$(datadir)
+
+ uninstall:
+ @$(RM) $(bindir)/@PACKAGE_NAME@
diff --git a/debian/patches/01-remove-extra-copyright-file.patch b/debian/patches/01-remove-extra-copyright-file.patch
deleted file mode 100644
index 6a419ac..0000000
--- a/debian/patches/01-remove-extra-copyright-file.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-From: Jonathan McCrohan <jmccrohan@gmail.com>
-Date: Sun, 10 Jun 2012 00:31:09 +0100
-Subject: Remove extra copyright file from Makefile
-Last-Update: 2014-01-25
-
-diff --git a/Makefile.in b/Makefile.in
-index 0b27ad7..e48e174 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -22,7 +22,7 @@ MAIN = @PACKAGE_NAME@.c
- HEADERS = @PACKAGE_NAME@.h llist.h iw_if.h
- PURESRC = $(filter-out $(MAIN),$(wildcard *.c))
- OBJS = $(PURESRC:.c=.o)
--DOCS = README NEWS THANKS AUTHORS COPYING ChangeLog
-+DOCS = README NEWS THANKS AUTHORS ChangeLog
-
- %.o: %.c $(HEADERS)
- $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(DEFS) -c -o $@ $<
diff --git a/debian/patches/series b/debian/patches/series
index f5eb0a6..18ef635 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1 @@
-01-remove-extra-copyright-file.patch
+01-patch-makefile.in-to-not-install-docs.patch
diff --git a/debian/wavemon.docs b/debian/wavemon.docs
new file mode 100644
index 0000000..05c2865
--- /dev/null
+++ b/debian/wavemon.docs
@@ -0,0 +1,4 @@
+AUTHORS
+NEWS
+README
+THANKS