aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/01-patch-makefile.in-to-not-install-docs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/01-patch-makefile.in-to-not-install-docs.patch')
-rw-r--r--debian/patches/01-patch-makefile.in-to-not-install-docs.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/patches/01-patch-makefile.in-to-not-install-docs.patch b/debian/patches/01-patch-makefile.in-to-not-install-docs.patch
new file mode 100644
index 0000000..e000145
--- /dev/null
+++ b/debian/patches/01-patch-makefile.in-to-not-install-docs.patch
@@ -0,0 +1,31 @@
+From: Jonathan McCrohan <jmccrohan@gmail.com>
+Date: Sun, 23 Mar 2014 01:02:44 +0000
+Subject: Patch Makefile.in to not install docs; install using dh instead
+
+diff --git a/Makefile.in b/Makefile.in
+index 0b27ad7..3cc8acc 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -22,7 +22,6 @@ MAIN = @PACKAGE_NAME@.c
+ HEADERS = @PACKAGE_NAME@.h llist.h iw_if.h
+ PURESRC = $(filter-out $(MAIN),$(wildcard *.c))
+ OBJS = $(PURESRC:.c=.o)
+-DOCS = README NEWS THANKS AUTHORS COPYING ChangeLog
+
+ %.o: %.c $(HEADERS)
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(DEFS) -c -o $@ $<
+@@ -49,13 +48,11 @@ install-suid-root install-binaries: all
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(bindir)
+ $(INSTALL) -m $(exec_perms) @PACKAGE_NAME@ $(DESTDIR)$(bindir)
+
+-install-docs: @PACKAGE_NAME@.1 @PACKAGE_NAME@rc.5 $(DOCS)
++install-docs: @PACKAGE_NAME@.1 @PACKAGE_NAME@rc.5
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 0644 @PACKAGE_NAME@.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man5
+ $(INSTALL) -m 0644 @PACKAGE_NAME@rc.5 $(DESTDIR)$(mandir)/man5
+- $(INSTALL) -m 0755 -d $(DESTDIR)$(datadir)
+- $(INSTALL) -m 0644 $(DOCS) $(DESTDIR)$(datadir)
+
+ uninstall:
+ @$(RM) $(bindir)/@PACKAGE_NAME@