aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2016-01-30 18:39:56 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2016-01-30 18:39:56 +0000
commit4955a98d6987c979075679f07fd3978cf82051d0 (patch)
treee210bc4badaf9bce384f6b3d1aedc6f8db0c24d8
parent84abb04c32223bc437796006cea2f405a8ed4e15 (diff)
downloadwavemon-4955a98d6987c979075679f07fd3978cf82051d0.tar.gz
d/patches: refresh patches
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/01-patch-makefile.in-to-not-install-docs.patch10
-rw-r--r--debian/patches/02-patch-configure.ac-to-allow-external-build_date.patch62
-rw-r--r--debian/patches/series1
4 files changed, 9 insertions, 68 deletions
diff --git a/debian/changelog b/debian/changelog
index c3ee63d..215f269 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,10 @@ wavemon (0.8.0-1) UNRELEASED; urgency=medium
- Updated scan and info screens
- Drop random signals functionality
* d/watch: upstream has moved to github; update accordingly
+ * d/patches:
+ - refresh 01-patch-makefile.in-to-not-install-docs.patch
+ - drop 02-patch-configure.ac-to-allow-external-build_date.patch; applied
+ upstream
-- Jonathan McCrohan <jmccrohan@gmail.com> Sat, 30 Jan 2016 16:52:38 +0000
diff --git a/debian/patches/01-patch-makefile.in-to-not-install-docs.patch b/debian/patches/01-patch-makefile.in-to-not-install-docs.patch
index e000145..1efd0d8 100644
--- a/debian/patches/01-patch-makefile.in-to-not-install-docs.patch
+++ b/debian/patches/01-patch-makefile.in-to-not-install-docs.patch
@@ -3,18 +3,18 @@ Date: Sun, 23 Mar 2014 01:02:44 +0000
Subject: Patch Makefile.in to not install docs; install using dh instead
diff --git a/Makefile.in b/Makefile.in
-index 0b27ad7..3cc8acc 100644
+index d2e1c01..d8a579b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -22,7 +22,6 @@ MAIN = @PACKAGE_NAME@.c
- HEADERS = @PACKAGE_NAME@.h llist.h iw_if.h
+ HEADERS = $(wildcard *.h)
PURESRC = $(filter-out $(MAIN),$(wildcard *.c))
OBJS = $(PURESRC:.c=.o)
--DOCS = README NEWS THANKS AUTHORS COPYING ChangeLog
+-DOCS = README.md NEWS THANKS AUTHORS COPYING ChangeLog
%.o: %.c $(HEADERS)
- $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(DEFS) -c -o $@ $<
-@@ -49,13 +48,11 @@ install-suid-root install-binaries: all
+ @echo ' CC ' $<
+@@ -50,13 +49,11 @@ install-suid-root install-binaries: all
$(INSTALL) -m 0755 -d $(DESTDIR)$(bindir)
$(INSTALL) -m $(exec_perms) @PACKAGE_NAME@ $(DESTDIR)$(bindir)
diff --git a/debian/patches/02-patch-configure.ac-to-allow-external-build_date.patch b/debian/patches/02-patch-configure.ac-to-allow-external-build_date.patch
deleted file mode 100644
index 6026187..0000000
--- a/debian/patches/02-patch-configure.ac-to-allow-external-build_date.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From b951f6292f74edd114a403b6be8752070c8d819f Mon Sep 17 00:00:00 2001
-From: Jonathan McCrohan <jmccrohan@gmail.com>
-Date: Thu, 12 Mar 2015 15:21:58 -0700
-Subject: [PATCH] configure.ac: Support external BUILD_DATE values
-
-Support reproducible builds [1] by allowing build systems to pass in an
-external value for BUILD_DATE.
-
-autoreconf has been run to resync configure with configure.ac changes.
-
-[1] https://wiki.debian.org/ReproducibleBuilds
-
-Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com>
-Signed-off-by: Gerrit Renker <gerrit@erg.abdn.ac.uk>
----
- configure | 8 ++++++++
- configure.ac | 7 ++++++-
- 2 files changed, 14 insertions(+), 1 deletion(-)
-
-diff --git a/configure b/configure
-index 082dd99..eeb8115 100755
---- a/configure
-+++ b/configure
-@@ -2186,11 +2186,19 @@ ac_configure="$SHELL $ac_aux_dir/configure" # Please don't use this var.
-
- ac_config_files="$ac_config_files Makefile"
-
-+# allow BUILD_DATE to be externally set for build reproducibility
-+if test "$BUILD_DATE"; then
-+ cat >>confdefs.h <<_ACEOF
-+#define BUILD_DATE "$BUILD_DATE"
-+_ACEOF
-+
-+else
-
- cat >>confdefs.h <<_ACEOF
- #define BUILD_DATE "`/bin/date`"
- _ACEOF
-
-+fi
-
- CFLAGS="-O2 -Wall"
-
-diff --git a/configure.ac b/configure.ac
-index e50c986..7ae0db9 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -7,8 +7,13 @@ AC_INIT([wavemon], [0.7.6], [gerrit@erg.abdn.ac.uk], [wavemon-current],
- # Variables
- AC_CONFIG_AUX_DIR([config])
- AC_CONFIG_FILES([Makefile])
--AC_DEFINE_UNQUOTED([BUILD_DATE], ["`/bin/date`"],
-+# allow BUILD_DATE to be externally set for build reproducibility
-+if test "$BUILD_DATE"; then
-+ AC_DEFINE_UNQUOTED(BUILD_DATE, ["$BUILD_DATE"])
-+else
-+ AC_DEFINE_UNQUOTED([BUILD_DATE], ["`/bin/date`"],
- [date wavemon was last configured and built])
-+fi
-
- CFLAGS="-O2 -Wall"
-
diff --git a/debian/patches/series b/debian/patches/series
index 3c4f399..18ef635 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1 @@
01-patch-makefile.in-to-not-install-docs.patch
-02-patch-configure.ac-to-allow-external-build_date.patch