aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/01-patch-makefile.in-to-not-install-docs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/01-patch-makefile.in-to-not-install-docs.patch')
-rw-r--r--debian/patches/01-patch-makefile.in-to-not-install-docs.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/debian/patches/01-patch-makefile.in-to-not-install-docs.patch b/debian/patches/01-patch-makefile.in-to-not-install-docs.patch
index e000145..1efd0d8 100644
--- a/debian/patches/01-patch-makefile.in-to-not-install-docs.patch
+++ b/debian/patches/01-patch-makefile.in-to-not-install-docs.patch
@@ -3,18 +3,18 @@ Date: Sun, 23 Mar 2014 01:02:44 +0000
Subject: Patch Makefile.in to not install docs; install using dh instead
diff --git a/Makefile.in b/Makefile.in
-index 0b27ad7..3cc8acc 100644
+index d2e1c01..d8a579b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -22,7 +22,6 @@ MAIN = @PACKAGE_NAME@.c
- HEADERS = @PACKAGE_NAME@.h llist.h iw_if.h
+ HEADERS = $(wildcard *.h)
PURESRC = $(filter-out $(MAIN),$(wildcard *.c))
OBJS = $(PURESRC:.c=.o)
--DOCS = README NEWS THANKS AUTHORS COPYING ChangeLog
+-DOCS = README.md NEWS THANKS AUTHORS COPYING ChangeLog
%.o: %.c $(HEADERS)
- $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(DEFS) -c -o $@ $<
-@@ -49,13 +48,11 @@ install-suid-root install-binaries: all
+ @echo ' CC ' $<
+@@ -50,13 +49,11 @@ install-suid-root install-binaries: all
$(INSTALL) -m 0755 -d $(DESTDIR)$(bindir)
$(INSTALL) -m $(exec_perms) @PACKAGE_NAME@ $(DESTDIR)$(bindir)