aboutsummaryrefslogtreecommitdiffstats
path: root/util/ttusb_dec_reset/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'util/ttusb_dec_reset/Makefile')
-rw-r--r--util/ttusb_dec_reset/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/util/ttusb_dec_reset/Makefile b/util/ttusb_dec_reset/Makefile
new file mode 100644
index 0000000..cde7de5
--- /dev/null
+++ b/util/ttusb_dec_reset/Makefile
@@ -0,0 +1,17 @@
+CC = gcc
+RM = rm -f
+CFLAGS = -g -Wall -O2
+LFLAGS = -g -Wall
+LDFLAGS = -lusb
+
+OBJS = ttusb_dec_reset.o
+TARGET = ttusb_dec_reset
+
+$(TARGET): $(OBJS)
+ $(CC) $(LFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJS)
+
+.c.o:
+ $(CC) $(CFLAGS) -c $< -o $@
+
+clean:
+ $(RM) *.o $(TARGET)