aboutsummaryrefslogtreecommitdiffstats
path: root/util/dvbnet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'util/dvbnet/Makefile')
-rw-r--r--util/dvbnet/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/util/dvbnet/Makefile b/util/dvbnet/Makefile
new file mode 100644
index 0000000..187dee2
--- /dev/null
+++ b/util/dvbnet/Makefile
@@ -0,0 +1,29 @@
+
+CC = gcc
+CFLAGS = -g -O2 -MD -Wall -I. -I../../include
+LFLAGS =
+
+OBJS = dvbnet.o
+TARGET = dvbnet
+DESTDIR = /usr/local/bin/
+
+all: version.h $(TARGET)
+
+.c.o:
+ $(CC) $(CFLAGS) -c $< -o $@
+
+$(TARGET): $(OBJS)
+ $(CC) -o $@ $(OBJS) $(LFLAGS)
+
+version.h:
+ printf '#define VERSION_INFO "%s (Build %s)"\n' \
+ "`cat $@.in`" "`date +'%a %b %d %X %Y'`" > $@
+
+install: all
+ install -m 755 $(TARGET) $(DESTDIR)
+
+clean:
+ rm -f $(TARGET) $(OBJS) version.h core* *~ *.d
+
+-include $(wildcard *.d) dummy
+