aboutsummaryrefslogtreecommitdiffstats
path: root/util/dvbnet/Makefile
diff options
context:
space:
mode:
authoretobi <git@e-tobi.net>2013-09-03 09:48:38 +0200
committeretobi <git@e-tobi.net>2013-09-03 09:48:38 +0200
commit6e40287e2f39a80fc72bd8d0fbc1a8334d688c2d (patch)
tree024bef311226653bdd1da4fa588becf5098bcff7 /util/dvbnet/Makefile
downloadlinux-dvb-apps-6e40287e2f39a80fc72bd8d0fbc1a8334d688c2d.tar.gz
Imported Upstream version 1.1.0upstream/1.1.0
Diffstat (limited to 'util/dvbnet/Makefile')
-rw-r--r--util/dvbnet/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/util/dvbnet/Makefile b/util/dvbnet/Makefile
new file mode 100644
index 0000000..187dee2
--- /dev/null
+++ b/util/dvbnet/Makefile
@@ -0,0 +1,29 @@
+
+CC = gcc
+CFLAGS = -g -O2 -MD -Wall -I. -I../../include
+LFLAGS =
+
+OBJS = dvbnet.o
+TARGET = dvbnet
+DESTDIR = /usr/local/bin/
+
+all: version.h $(TARGET)
+
+.c.o:
+ $(CC) $(CFLAGS) -c $< -o $@
+
+$(TARGET): $(OBJS)
+ $(CC) -o $@ $(OBJS) $(LFLAGS)
+
+version.h:
+ printf '#define VERSION_INFO "%s (Build %s)"\n' \
+ "`cat $@.in`" "`date +'%a %b %d %X %Y'`" > $@
+
+install: all
+ install -m 755 $(TARGET) $(DESTDIR)
+
+clean:
+ rm -f $(TARGET) $(OBJS) version.h core* *~ *.d
+
+-include $(wildcard *.d) dummy
+