aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/add-pkgconfig-support.patch45
-rw-r--r--debian/patches/fix-recieved-typos.patch90
-rw-r--r--debian/patches/series2
3 files changed, 137 insertions, 0 deletions
diff --git a/debian/patches/add-pkgconfig-support.patch b/debian/patches/add-pkgconfig-support.patch
new file mode 100644
index 0000000..bc68540
--- /dev/null
+++ b/debian/patches/add-pkgconfig-support.patch
@@ -0,0 +1,45 @@
+Description: Add pkgconfig support
+Author: Jonathan McCrohan <jmccrohan@gmail.com>
+Date: Thu, 26 Apr 2012 00:26:23 +0100
+---
+--- /dev/null
++++ libphidget-2.1.8.20120216/libphidget21.pc.in
+@@ -0,0 +1,10 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: libphidget21
++Description: Phidgets library
++Version: @VERSION@
++Libs: -L${libdir} -lphidgets21
++Cflags: -I${includedir}
+--- libphidget-2.1.8.20120216.orig/configure.ac
++++ libphidget-2.1.8.20120216/configure.ac
+@@ -91,4 +91,4 @@ AM_CONDITIONAL([INTERNAL_UNICONV], [test
+
+ AC_CONFIG_FILES([Makefile
+ examples/Makefile])
+-AC_OUTPUT
++AC_OUTPUT([libphidget21.pc])
+--- libphidget-2.1.8.20120216.orig/Makefile.am
++++ libphidget-2.1.8.20120216/Makefile.am
+@@ -2,6 +2,9 @@
+
+ AM_CFLAGS = -I$(top_srcdir) -I$(top_srcdir)/utils -I$(top_srcdir)/dict -I$(top_srcdir)/linux -I$(top_srcdir)/include -D_LINUX
+
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = libphidget21.pc
++
+ lib_LTLIBRARIES = libphidget21.la
+
+ # Rules for unpdating the libtool version:
+@@ -119,6 +122,7 @@ EXTRA_DIST = examples/ifkit.c \
+ hotplug/phidgets.usermap \
+ hotplug/phidgets \
+ version.sh \
++ libphidget21.pc.in \
+ Java/com/phidgets/DictionaryKeyListener.java \
+ Java/com/phidgets/TextLCDPhidget.java \
+ Java/com/phidgets/SpatialEventData.java \
diff --git a/debian/patches/fix-recieved-typos.patch b/debian/patches/fix-recieved-typos.patch
new file mode 100644
index 0000000..17aba79
--- /dev/null
+++ b/debian/patches/fix-recieved-typos.patch
@@ -0,0 +1,90 @@
+Description: Fix 'recieved' typos
+Author: Jonathan McCrohan <jmccrohan@gmail.com>
+Date: Thu, 26 Apr 2012 00:28:52 +0100
+---
+--- libphidget-2.1.8.20120216.orig/cphidgetstepper.c
++++ libphidget-2.1.8.20120216/cphidgetstepper.c
+@@ -238,7 +238,7 @@ CPHIDGETDATA(Stepper)
+ phid->motorPositionEcho[i] = position[i];
+
+ if(speed[i] > phid->motorSpeedMax || speed[i] < -phid->motorSpeedMax)
+- LOG(PHIDGET_LOG_WARNING, "Phidget stepper recieved out of range speed data: %lE", speed[i]);
++ LOG(PHIDGET_LOG_WARNING, "Phidget stepper received out of range speed data: %lE", speed[i]);
+ else
+ phid->motorSpeedEcho[i] = speed[i];
+
+--- libphidget-2.1.8.20120216.orig/cphidgetadvancedservo.c
++++ libphidget-2.1.8.20120216/cphidgetadvancedservo.c
+@@ -310,7 +310,7 @@ CPHIDGETDATA(AdvancedServo)
+ else
+ phid->motorPositionEcho[i] = position[i];
+ if(velocity[i] > phid->velocityMaxLimit || velocity[i] < -phid->velocityMaxLimit)
+- LOG(PHIDGET_LOG_WARNING, "Phidget advanced servo recieved out of range velocity data: %lE", velocity[i]);
++ LOG(PHIDGET_LOG_WARNING, "Phidget advanced servo received out of range velocity data: %lE", velocity[i]);
+ else
+ phid->motorVelocityEcho[i] = velocity[i];
+
+--- libphidget-2.1.8.20120216.orig/csocketopen.c
++++ libphidget-2.1.8.20120216/csocketopen.c
+@@ -1269,7 +1269,7 @@ start:
+ {
+ //if we've been waiting too long, then signal disconnect
+ double waitTime = timeSince(&server->lastHeartbeatTime);
+- //if we haven't recieved any heartbeats, set the timeout high (4*4 = 16 seconds)
++ //if we haven't received any heartbeats, set the timeout high (4*4 = 16 seconds)
+ //This is so that really slow connections will get through the auth stage
+ double avgPingTime = ((server->avgHeartbeatTimeCount > 0) ? (server->avgHeartbeatTime / server->avgHeartbeatTimeCount) : 4.0);
+
+--- libphidget-2.1.8.20120216.orig/cphidgetgps.c
++++ libphidget-2.1.8.20120216/cphidgetgps.c
+@@ -76,7 +76,7 @@ CPHIDGETINIT(GPS)
+ CUSBSendPacket((CPhidgetHandle)phid, buffer);*/
+
+ //read some initial data - rate is 10Hz so we shouldn't have to wait long
+- //This ensures we have recieved at least one GGA and one RMC
++ //This ensures we have received at least one GGA and one RMC
+ readtries = 30; //250ms
+ while((phid->fix==PUNK_BOOL || phid->haveTime==PUNK_BOOL || phid->haveDate==PUNK_BOOL) && readtries)
+ {
+--- libphidget-2.1.8.20120216.orig/Java/com/phidgets/IRPhidget.java
++++ libphidget-2.1.8.20120216/Java/com/phidgets/IRPhidget.java
+@@ -124,7 +124,7 @@ public final class IRPhidget extends Phi
+ return readRaw (buffer, 0, buffer.length);
+ }
+ /**
+- * Returns the last recieved code. This is updated right after the code event returns.
++ * Returns the last received code. This is updated right after the code event returns.
+ * @return last code
+ * @throws PhidgetException If this Phidget is not opened and attached.
+ * See {@link com.phidgets.Phidget#open(int) open} for information on determining if a device is attached.
+@@ -207,7 +207,7 @@ public final class IRPhidget extends Phi
+ }
+ private native void enableLearnEvents (boolean b);
+ /**
+- * Adds a rawData listener. The rawData handler is a method that will be called when a raw IR data is recieved.
++ * Adds a rawData listener. The rawData handler is a method that will be called when a raw IR data is received.
+ * <p>
+ * There is no limit on the number of rawData handlers that can be registered for a particular Phidget.
+ *
+--- libphidget-2.1.8.20120216.orig/Java/com/phidgets/Manager.java
++++ libphidget-2.1.8.20120216/Java/com/phidgets/Manager.java
+@@ -195,7 +195,7 @@ public class Manager
+
+ /**
+ * Shuts down the Phidget Manager. This method should be called to close down the Phidget Manager.
+- * Events will no longer be recieved. This method gets calledd automatically when the class is
++ * Events will no longer be received. This method gets calledd automatically when the class is
+ * destroyed so calling it is not required.
+ */
+ public final void close() throws PhidgetException {
+--- libphidget-2.1.8.20120216.orig/utils/utils.c
++++ libphidget-2.1.8.20120216/utils/utils.c
+@@ -911,7 +911,7 @@ tryagain:
+ return 0;
+ } else
+ {
+- pu_log(PUL_VERB,0,"Recieved: \"%s\"", (char *)buf);
++ pu_log(PUL_VERB,0,"Received: \"%s\"", (char *)buf);
+ return res;
+ }
+ }
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..ba9de47
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+add-pkgconfig-support.patch
+fix-recieved-typos.patch