aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/add-pkgconfig-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/add-pkgconfig-support.patch')
-rw-r--r--debian/patches/add-pkgconfig-support.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/debian/patches/add-pkgconfig-support.patch b/debian/patches/add-pkgconfig-support.patch
new file mode 100644
index 0000000..bc68540
--- /dev/null
+++ b/debian/patches/add-pkgconfig-support.patch
@@ -0,0 +1,45 @@
+Description: Add pkgconfig support
+Author: Jonathan McCrohan <jmccrohan@gmail.com>
+Date: Thu, 26 Apr 2012 00:26:23 +0100
+---
+--- /dev/null
++++ libphidget-2.1.8.20120216/libphidget21.pc.in
+@@ -0,0 +1,10 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: libphidget21
++Description: Phidgets library
++Version: @VERSION@
++Libs: -L${libdir} -lphidgets21
++Cflags: -I${includedir}
+--- libphidget-2.1.8.20120216.orig/configure.ac
++++ libphidget-2.1.8.20120216/configure.ac
+@@ -91,4 +91,4 @@ AM_CONDITIONAL([INTERNAL_UNICONV], [test
+
+ AC_CONFIG_FILES([Makefile
+ examples/Makefile])
+-AC_OUTPUT
++AC_OUTPUT([libphidget21.pc])
+--- libphidget-2.1.8.20120216.orig/Makefile.am
++++ libphidget-2.1.8.20120216/Makefile.am
+@@ -2,6 +2,9 @@
+
+ AM_CFLAGS = -I$(top_srcdir) -I$(top_srcdir)/utils -I$(top_srcdir)/dict -I$(top_srcdir)/linux -I$(top_srcdir)/include -D_LINUX
+
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = libphidget21.pc
++
+ lib_LTLIBRARIES = libphidget21.la
+
+ # Rules for unpdating the libtool version:
+@@ -119,6 +122,7 @@ EXTRA_DIST = examples/ifkit.c \
+ hotplug/phidgets.usermap \
+ hotplug/phidgets \
+ version.sh \
++ libphidget21.pc.in \
+ Java/com/phidgets/DictionaryKeyListener.java \
+ Java/com/phidgets/TextLCDPhidget.java \
+ Java/com/phidgets/SpatialEventData.java \