aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-02-26 20:50:11 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2012-02-26 20:50:11 +0000
commitb29d1bc94f06ec1a4788720551f601841db28292 (patch)
tree67ad63c5a1299f40dc115ceced1915ea9c118bd5
parent9bd1d9c313e7953496c7d17fb803db25859458d0 (diff)
downloadlibconfig-b29d1bc94f06ec1a4788720551f601841db28292.tar.gz
Clean up rules file.
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules31
2 files changed, 12 insertions, 25 deletions
diff --git a/debian/changelog b/debian/changelog
index 3e046bc..8ac6f15 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+libconfig (1.4.8-1~exp2) experimental; urgency=low
+
+ * Harden buildflags
+
+ -- Jonathan McCrohan <jmccrohan@gmail.com> Sun, 26 Feb 2012 20:49:10 +0000
+
libconfig (1.4.8-1~exp1) experimental; urgency=low
* New upstream release (closes: #583528)
diff --git a/debian/rules b/debian/rules
index efbfd8a..23dad68 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,30 +1,15 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-LIBS = $(shell grep '^Package: lib' debian/control | egrep -v '(-doc|-dev)' | sed -e 's@Package: @@' )
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-include /usr/share/quilt/quilt.make
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
+CFLAGS = $(dpkg-buildflags --get CFLAGS)
+CFLAGS += -Wall -g
+LDFLAGS = $(dpkg-buildflags --get LDFLAGS)
+LDFLAGS += defs
+CPPFLAGS = $(dpkg-buildflags --get CPPFLAGS)
# shared library versions, option 1
version=9
@@ -43,10 +28,6 @@ config.status: configure
--prefix=/usr \
--mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info
- CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
-
-configure: patch
- #$(RM) debian/libconfig9.info debian/shlibs
build: build-arch build-indep
@@ -63,7 +44,7 @@ build-stamp: config.status
$(MAKE) -C doc pdf
touch $@
-clean: unpatch
+clean:
dh_testdir
dh_testroot