aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-02-26 20:43:10 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2012-02-26 20:43:10 +0000
commit9bd1d9c313e7953496c7d17fb803db25859458d0 (patch)
tree3dc2d45ef21446427249846545c0a8b4dacddf4c
parent7020cf36b4fb1d8a333da27f1e53687892725223 (diff)
downloadlibconfig-9bd1d9c313e7953496c7d17fb803db25859458d0.tar.gz
Revert "Clean up debian/rules"
This reverts commit c6ac7aec24ec3a425e012031d94fea837758850e.
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules32
2 files changed, 24 insertions, 14 deletions
diff --git a/debian/changelog b/debian/changelog
index 8c2ae7f..3e046bc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,3 @@
-libconfig (1.4.8-1~exp2) experimental; urgency=low
-
- * Enable hardened build flags.
-
- -- Jonathan McCrohan <jmccrohan@gmail.com> Wed, 22 Feb 2012 00:51:01 +0000
-
libconfig (1.4.8-1~exp1) experimental; urgency=low
* New upstream release (closes: #583528)
diff --git a/debian/rules b/debian/rules
index 7df4e75..efbfd8a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,22 +1,37 @@
#!/usr/bin/make -f
# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+LIBS = $(shell grep '^Package: lib' debian/control | egrep -v '(-doc|-dev)' | sed -e 's@Package: @@' )
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-CFLAGS = $(dpkg-buildflags --get CFLAGS)
-CFLAGS += -Wall
-LDFLAGS = $(dpkg-buildflags --get LDFLAGS)
-LDFLAGS += defs
-CPPFLAGS = $(dpkg-buildflags --get CPPFLAGS)
+include /usr/share/quilt/quilt.make
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
# shared library versions, option 1
version=9
major=9
minor=0
+
config.status: configure
dh_testdir
test -e config.sub -a -L config.sub || \
@@ -24,13 +39,14 @@ config.status: configure
test -e config.guess -a -L config.guess || \
ln -sf /usr/share/misc/config.guess config.guess
- CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" \
./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
--prefix=/usr \
--mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info
+ CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
-configure:
+configure: patch
+ #$(RM) debian/libconfig9.info debian/shlibs
build: build-arch build-indep
@@ -47,7 +63,7 @@ build-stamp: config.status
$(MAKE) -C doc pdf
touch $@
-clean:
+clean: unpatch
dh_testdir
dh_testroot