aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9229002..b774125 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-# $Id: Makefile.am 1158 2011-07-28 02:09:16Z michael $
+# $Id: Makefile.am 1177 2012-02-22 03:11:31Z michael $
# $URL: https://ssl.bulix.org/svn/lcd4linux/trunk/Makefile.am $
# Process this file with automake to produce Makefile.in
@@ -18,7 +18,7 @@ ACLOCAL_AMFLAGS=-I m4
# use this for lots of warnings
#AM_CFLAGS = -D_GNU_SOURCE -std=c99 -m64 -Wall -W -pedantic -Wno-variadic-macros -fno-strict-aliasing
-lcd4linux_LDFLAGS =
+lcd4linux_LDFLAGS ="-Wl,--as-needed"
lcd4linux_LDADD = @DRIVERS@ @PLUGINS@ @DRVLIBS@ @PLUGINLIBS@
lcd4linux_DEPENDENCIES = @DRIVERS@ @PLUGINS@
@@ -78,8 +78,10 @@ drv_Crystalfontz.c \
drv_Curses.c \
drv_Cwlinux.c \
drv_D4D.c \
+drv_dpf.c \
drv_EA232graphic.c \
drv_EFN.c \
+drv_FutabaVFD.c \
drv_FW8888.c \
drv_G15.c \
drv_GLCD2USB.c glcd2usb.h \
@@ -108,11 +110,13 @@ drv_picoLCD.c \
drv_picoLCDGraphic.c \
drv_RouterBoard.c \
drv_Sample.c \
+drv_SamsungSPF.c \
drv_st2205.c \
drv_serdisplib.c \
drv_ShuttleVFD.c \
drv_SimpleLCD.c \
drv_T6963.c \
+drv_TeakLCM.c \
drv_Trefon.c \
drv_ula200.c \
drv_USBHUB.c \