aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-03-08 21:20:23 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2012-03-08 21:20:23 +0000
commit3b03ff939fd1ae525db8477f28883fc011997029 (patch)
treec4b8ad775bc5bf6d03a06d035a3279d12c2a02b6 /Makefile.am
parent7ca8e0e2e74a3f53e6e119b8bdfb2771523caa7f (diff)
parentd0b266cf85d3c7733259c76831de0cfd4c1731a1 (diff)
downloadlcd4linux-3b03ff939fd1ae525db8477f28883fc011997029.tar.gz
* New upstream snapshot
- adds new DPF driver - adds new TeakLCM driver - adds new Futaba VFD driver - adds new Samsung SPF driver
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9229002..b774125 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-# $Id: Makefile.am 1158 2011-07-28 02:09:16Z michael $
+# $Id: Makefile.am 1177 2012-02-22 03:11:31Z michael $
# $URL: https://ssl.bulix.org/svn/lcd4linux/trunk/Makefile.am $
# Process this file with automake to produce Makefile.in
@@ -18,7 +18,7 @@ ACLOCAL_AMFLAGS=-I m4
# use this for lots of warnings
#AM_CFLAGS = -D_GNU_SOURCE -std=c99 -m64 -Wall -W -pedantic -Wno-variadic-macros -fno-strict-aliasing
-lcd4linux_LDFLAGS =
+lcd4linux_LDFLAGS ="-Wl,--as-needed"
lcd4linux_LDADD = @DRIVERS@ @PLUGINS@ @DRVLIBS@ @PLUGINLIBS@
lcd4linux_DEPENDENCIES = @DRIVERS@ @PLUGINS@
@@ -78,8 +78,10 @@ drv_Crystalfontz.c \
drv_Curses.c \
drv_Cwlinux.c \
drv_D4D.c \
+drv_dpf.c \
drv_EA232graphic.c \
drv_EFN.c \
+drv_FutabaVFD.c \
drv_FW8888.c \
drv_G15.c \
drv_GLCD2USB.c glcd2usb.h \
@@ -108,11 +110,13 @@ drv_picoLCD.c \
drv_picoLCDGraphic.c \
drv_RouterBoard.c \
drv_Sample.c \
+drv_SamsungSPF.c \
drv_st2205.c \
drv_serdisplib.c \
drv_ShuttleVFD.c \
drv_SimpleLCD.c \
drv_T6963.c \
+drv_TeakLCM.c \
drv_Trefon.c \
drv_ula200.c \
drv_USBHUB.c \