aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-05-19 14:45:33 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2012-05-19 14:45:33 +0100
commit62cdef067360a2550a2594944885c4f111b4aae7 (patch)
treebc4c0ef429058efb134f56176d6745bd585a2505
parent280bb6fe8dc289551d6d3cd14634af11651c5196 (diff)
downloadlcd4linux-62cdef067360a2550a2594944885c4f111b4aae7.tar.gz
Bump dh to v9
Switch to dh-style debian/rules
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat2
-rw-r--r--debian/control9
-rwxr-xr-xdebian/rules83
4 files changed, 17 insertions, 82 deletions
diff --git a/debian/changelog b/debian/changelog
index c488b4c..a37134f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,13 @@
-lcd4linux (0.11.0~svn1188-1) UNRELEASED; urgency=low
+lcd4linux (0.11.0~svn1189-1) UNRELEASED; urgency=low
* New upstream snapshot
- Adds Hex support to the evaluator
- Fixes -Wimplicit-function-declaration build warnings
+ - Fixes -Werror=format-security build errors
- Fixes plugin_file syslog flood if file does not exist
* d/rules: Add get-orig-source target
+ * Bump dh to v9
+ * Switch to dh-style debian/rules
-- Jonathan McCrohan <jmccrohan@gmail.com> Thu, 17 May 2012 01:14:40 +0100
diff --git a/debian/compat b/debian/compat
index 7f8f011..ec63514 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-7
+9
diff --git a/debian/control b/debian/control
index 64f7a58..e6b80b5 100644
--- a/debian/control
+++ b/debian/control
@@ -4,14 +4,19 @@ Priority: optional
Maintainer: Reinhard Tartler <siretart@tauware.de>
Uploaders: Jonathan McCrohan <jmccrohan@gmail.com>
Build-Depends:
- debhelper (>= 7.0.0),
+ autotools-dev,
+ debhelper (>= 9),
dh-autoreconf,
libdbus-1-dev,
- libgd2-noxpm-dev,
+ libftdi-dev,
+ libgd2-xpm-dev,
+ libgphoto2-2-dev,
+ libmpdclient-dev,
libmysqlclient-dev,
libncurses5-dev,
libsqlite3-dev,
libusb-dev,
+ libvncserver-dev,
libx11-dev,
libxt-dev,
python-dev
diff --git a/debian/rules b/debian/rules
index 025a326..8f66c5a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,31 +4,10 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-# FOR AUTOCONF 2.52 AND NEWER ONLY
-ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
- confflags += --build $(DEB_HOST_GNU_TYPE)
-else
- confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
-endif
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-config.status: configure
- dh_testdir
+override_dh_auto_configure:
ln -s . m4
dh_autoreconf
- ./configure $(confflags) \
+ dh_auto_configure -- \
--prefix=/usr \
--mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info \
@@ -37,63 +16,11 @@ config.status: configure
# Enable raw parallel port I/O
# --with-outb
-# call this target to update config.sub and config.guess
-# need autotools-dev installed
-update-config-sub-guess:
- -test -r /usr/share/misc/config.sub && \
- cp -f /usr/share/misc/config.sub config.sub
- -test -r /usr/share/misc/config.guess && \
- cp -f /usr/share/misc/config.guess config.guess
-
-build: build-arch build-indep
-
-build-arch: build-stamp
-
-build-indep: build-stamp
-
-build-stamp: config.status
- dh_testdir
- $(MAKE)
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- [ ! -f Makefile ] || $(MAKE) distclean
- dh_autoreconf_clean
- dh_clean build-stamp m4
-
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
- $(MAKE) install DESTDIR=$(CURDIR)/debian/lcd4linux
-
-binary-indep:
-# No arch independent things to do here...
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples
- dh_install
- dh_installinit
+override_dh_installman:
dh_installman debian/lcd4linux.8
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+%:
+ dh $@ --with autotools_dev
get-orig-source:
debian/get-svn-source.sh