aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules83
1 files changed, 5 insertions, 78 deletions
diff --git a/debian/rules b/debian/rules
index 025a326..8f66c5a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,31 +4,10 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-# FOR AUTOCONF 2.52 AND NEWER ONLY
-ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
- confflags += --build $(DEB_HOST_GNU_TYPE)
-else
- confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
-endif
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-config.status: configure
- dh_testdir
+override_dh_auto_configure:
ln -s . m4
dh_autoreconf
- ./configure $(confflags) \
+ dh_auto_configure -- \
--prefix=/usr \
--mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info \
@@ -37,63 +16,11 @@ config.status: configure
# Enable raw parallel port I/O
# --with-outb
-# call this target to update config.sub and config.guess
-# need autotools-dev installed
-update-config-sub-guess:
- -test -r /usr/share/misc/config.sub && \
- cp -f /usr/share/misc/config.sub config.sub
- -test -r /usr/share/misc/config.guess && \
- cp -f /usr/share/misc/config.guess config.guess
-
-build: build-arch build-indep
-
-build-arch: build-stamp
-
-build-indep: build-stamp
-
-build-stamp: config.status
- dh_testdir
- $(MAKE)
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- [ ! -f Makefile ] || $(MAKE) distclean
- dh_autoreconf_clean
- dh_clean build-stamp m4
-
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
- $(MAKE) install DESTDIR=$(CURDIR)/debian/lcd4linux
-
-binary-indep:
-# No arch independent things to do here...
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples
- dh_install
- dh_installinit
+override_dh_installman:
dh_installman debian/lcd4linux.8
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+%:
+ dh $@ --with autotools_dev
get-orig-source:
debian/get-svn-source.sh