/* $Id$ * $URL$ * * pure ncurses based text driver * * Copyright (C) 2004 Michael Reinelt * Copyright (C) 2004 The LCD4Linux Team * * based on the old Curses/Text driver which is * Copyright (C) 2001 Leopold Toetsch * * This file is part of LCD4Linux. * * LCD4Linux is free software; you can redistribute it and/or modify * it under the terms of the GNU General Public License as published by * the Free Software Foundation; either version 2, or (at your option) * any later version. * * LCD4Linux is distributed in the hope that it will be useful, * but WITHOUT ANY WARRANTY; without even the implied warranty of * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the * GNU General Public License for more details. * * You should have received a copy of the GNU General Public License * along with this program; if not, write to the Free Software * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. * */ /* * * exported fuctions: * * struct DRIVER drv_Curses * */ #include "config.h" #include #include #include #include #include #include "debug.h" #include "cfg.h" #include "qprintf.h" #include "timer.h" #include "plugin.h" #include "widget.h" #include "widget_text.h" #include "widget_bar.h" #include "widget_keypad.h" #include "drv.h" #include "drv_generic_text.h" #include "drv_generic_keypad.h" static char Name[] = "Curses"; static WINDOW *w = NULL; static WINDOW *e = NULL; static int EROWS; /****************************************/ /*** hardware dependant functions ***/ /****************************************/ static void drv_Curs_clear(void) { werase(w); box(w, 0, 0); wrefresh(w); } static void drv_Curs_write(const int row, const int col, const char *data, const int len) { int l = len; char *p; while ((p = strpbrk(data, "\r\n")) != NULL) { *p = '\0'; } if (col < DCOLS) { if (DCOLS - col < l) l = DCOLS - col; mvwprintw(w, row + 1, col + 1, "%.*s", l, data); wmove(w, DROWS + 1, 0); wrefresh(w); } } static void drv_Curs_defchar(const __attribute__ ((unused)) int ascii, const __attribute__ ((unused)) unsigned char *buffer) { /* empty */ } /* ncures scroll SIGSEGVs on my system, so this is a workaroud */ int curses_error(char *buffer) { static int lines = 0; static char *lb[100]; int start, i; char *p; if (e == NULL) return 0; /* replace \r, \n with underscores */ while ((p = strpbrk(buffer, "\r\n")) != NULL) { *p = '_'; } if (lines >= EROWS) { free(lb[0]); for (i = 1; i <= EROWS; i++) { lb[i - 1] = lb[i]; } start = 0; } else { start = lines; } lb[lines] = strdup(buffer); for (i = start; i <= lines; i++) { mvwprintw(e, i + 1, 1, "%s", lb[i]); wclrtoeol(e); } box(e, 0, 0); mvwprintw(e, 0, 3, "Stderr:"); wrefresh(e); if (lines < EROWS) lines++; return 1; } static int drv_Curs_start(const char *section, const int quiet) { char *s; if (!running_foreground) { error("%s: You want me to display on /dev/null? Sorry, I can't ...", Name); error("%s: Maybe you want me to run in foreground? Try '-F'", Name); return -1; } s = cfg_get(section, "Size", "20x4"); if (s == NULL || *s == '\0') { error("%s: no '%s.Size' entry from %s", Name, section, cfg_source()); free(s); return -1; } if (sscanf(s, "%dx%d", &DCOLS, &DROWS) != 2 || DROWS < 1 || DCOLS < 1) { error("%s: bad %s.Size '%s' from %s", Name, section, s, cfg_source()); free(s); return -1; } free(s); initscr(); noecho(); debug("%s: curses thinks that COLS=%d LINES=%d", Name, COLS, LINES); w = newwin(DROWS + 2, DCOLS + 2, 0, 0); keypad(w, TRUE); nodelay(w, TRUE); EROWS = LINES - DROWS - 3; if
This package was debianized by Samuel Mimram <samuel.mimram@ens-lyon.org> on
Wed, 10 Dec 2003 11:48:10 +0100.

It was downloaded from http://lcd4linux.sourceforge.net/

Upstream Author: Michael Reinelt <reinelt@eunet.at>

Copyright: 1992, 1999-2004
The LCD4Linux Development Team <lcd4linux-devel@lists.sourceforge.net>
Michael Reinelt <reinelt@eunet.at>
Herbert Rosmanith <herp@wildsau.idv.uni-linz.ac.at>
Leopold T�tsch <lt@toetsch.at>
Axel Ehnert <axel@ehnert.net>
Andrew Ip <aip@cwlinux.com>
Robin Adams, Adams IT Services <info@usblcd.de>
Xavier Vello <xavier66@free.fr>
Martin Hejl (martin@hejl.de)
Jesse Brook Kovach <jkovach@wam.umd.edu>
Nico Wallmeier <nico.wallmeier@post.rwth-aachen.de>
Luis Correia <lfcorreia@users.sf.net>
Patrick Schemitz <schemitz@ekp.physik.uni-karlsruhe.de>
Andy Baxter <andy@earthsong.free-online.co.uk>
Thomas Siedentopf <thom-s@gmx.net>
Markus Keil <markus_keil@t-online.de>
Samuel Mimram <samuel.mimram@ens-lyon.fr>
Mark Morley <morley@Camosun.BC.CA>


This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; version 2 dated June, 1991.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

On Debian GNU/Linux systems, the complete text of the GNU General
Public License can be found in '/usr/share/common-licenses/GPL'.