aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 8 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index d89ff8e..e8a080d 100644
--- a/configure.in
+++ b/configure.in
@@ -59,11 +59,7 @@ for driver in $drivers; do
PNG="yes"
PPM="yes"
TEXT="yes"
- if test "$no_x" = "yes"; then
- X11="no"
- else
- X11="yes"
- fi
+ X11="yes"
;;
BeckmannEgle)
BECKMANNEGLE=$val
@@ -166,18 +162,13 @@ if test "$TEXT" = "yes"; then
fi
if test "$X11" = "yes"; then
- if test "$have_x" != yes; then
- AC_MSG_WARN(X not found: X11 driver disabled)
- else
- if test "$no_x" = "yes"; then
- AC_MSG_ERROR([cannot build X11 driver: headers or libraries not available])
- fi
- DRIVERS="$DRIVERS XWindow.o"
- # DRVLIBS="$DRVLIBS -lX11"
- DRVLIBS="$DRVLIBS -L$ac_x_libraries -lX11"
- # CPPFLAGS="$CPPFLAGS -I$ac_x_includes"
- AC_DEFINE(WITH_X11)
- fi
+ if test "$no_x" = "yes"; then
+ AC_MSG_ERROR(X11 headers or libraries not available: X11 driver disabled)
+ else
+ DRIVERS="$DRIVERS XWindow.o"
+ DRVLIBS="$DRVLIBS -L$ac_x_libraries -lX11"
+ AC_DEFINE(WITH_X11)
+ fi
fi
dnl Raster.o depends on PPM or PNG