aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorsiretart <siretart@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2006-09-04 16:41:21 +0000
committersiretart <siretart@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2006-09-04 16:41:21 +0000
commitb35e5d8bcfa6f0e8311f35aef78df2301f104e5f (patch)
treed021b253ec052ba1dd761de34336d3f6ffbb2885 /debian/rules
parent0ea9fcc19ca4afd2116817fa066709d840bab5f2 (diff)
downloadlcd4linux-b35e5d8bcfa6f0e8311f35aef78df2301f104e5f.tar.gz
[lcd4linux @ 2006-09-04 16:41:21 by siretart]
removing debianisation from upstream source, as discussed with Michael on private mail. Rationale: I try to keep an updated lcd4linux in debian/sid. If you need the debinisation, please use my packages as base. If you want more updated package, please drop me a note, and I'll arrange another upload to unstable (or experimental, depending on the state of the cvs). git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@704 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules86
1 files changed, 0 insertions, 86 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 4edc889..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-DESTDIR=$(CURDIR)/debian/lcd4linux
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-config.status: configure
- dh_testdir
- CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
- $(MAKE)
- #/usr/bin/docbook-to-man debian/lcd4linux.sgml > lcd4linux.1
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
-
- rm -f build-stamp
- -$(MAKE) distclean
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- $(MAKE) install DESTDIR=$(DESTDIR)
- mkdir -p $(DESTDIR)/etc
- cp lcd4linux.conf.sample $(DESTDIR)/etc/lcd4linux.conf
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
-# dh_installexamples
- dh_install
- dh_installdebconf
- dh_installinit
-# dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install