aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorreinelt <reinelt@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2004-02-15 21:43:43 +0000
committerreinelt <reinelt@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2004-02-15 21:43:43 +0000
commitbef230cf7300c25d25351615be378e62785f78cf (patch)
tree6e2799b6464df37df69358ed5a482546c4135796 /configure.in
parent0dc4d2093be753affc50d1ccb70fb9f5f66ed9b8 (diff)
downloadlcd4linux-bef230cf7300c25d25351615be378e62785f78cf.tar.gz
[lcd4linux @ 2004-02-15 21:43:43 by reinelt]
T6963 driver nearly finished framework for graphic displays done i2c_sensors patch from Xavier some more old generation files removed git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@367 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 13 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 731a3d5..cd157bc 100644
--- a/configure.in
+++ b/configure.in
@@ -142,7 +142,7 @@ AC_MSG_RESULT([done])
PARPORT="no"
SERIAL="no"
TEXT="no"
-RASTER="no"
+GRAPHIC="no"
if test "$BECKMANNEGLE" = "yes"; then
# DRIVERS="$DRIVERS BeckmannEgle.lo"
@@ -175,6 +175,7 @@ if test "$HD44780" = "yes"; then
fi
if test "$M50530" = "yes"; then
+ TEXT="yes"
PARPORT="yes"
# DRIVERS="$DRIVERS drv_M50530.lo"
DRIVERS="$DRIVERS drv_M50530.o"
@@ -182,13 +183,16 @@ if test "$M50530" = "yes"; then
fi
if test "$T6963" = "yes"; then
+ GRAPHIC="yes"
PARPORT="yes"
-# DRIVERS="$DRIVERS T6963.lo"
-# DRIVERS="$DRIVERS T6963.o"
+# DRIVERS="$DRIVERS drv_T6963.lo"
+ DRIVERS="$DRIVERS drv_T6963.o"
AC_DEFINE(WITH_T6963,1,[T6963 driver])
fi
if test "$USBLCD" = "yes"; then
+ TEXT="yes"
+ SERIAL="yes"
# DRIVERS="$DRIVERS drv_USBLCD.lo"
DRIVERS="$DRIVERS drv_USBLCD.o"
AC_DEFINE(WITH_USBLCD,1,[USBLCD driver])
@@ -215,7 +219,7 @@ fi
if test "$PNG" = "yes"; then
if test "$has_gd" = "true"; then
- RASTER="yes"
+ GRAPHIC="yes"
AC_DEFINE(WITH_PNG,1,[ driver])
DRVLIBS="$DRVLIBS -lgd"
else
@@ -225,7 +229,7 @@ fi
if test "$PPM" = "yes"; then
if test "$has_gd" = "true"; then
- RASTER="yes"
+ GRAPHIC="yes"
AC_DEFINE(WITH_PPM,1,[ driver])
else
AC_MSG_WARN(gd.h not found: PNG driver disabled)
@@ -265,11 +269,11 @@ if test "$TEXT" = "yes"; then
DRIVERS="$DRIVERS drv_generic_text.o"
fi
-# Raster.lo depends on PPM or PNG
-if test "$RASTER" = "yes"; then
+# generic graphic driver
+if test "$GRAPHIC" = "yes"; then
:
-# DRIVERS="$DRIVERS Raster.lo"
-# DRIVERS="$DRIVERS Raster.o"
+# DRIVERS="$DRIVERS
+ DRIVERS="$DRIVERS drv_generic_graphic.o"
fi
# generic parport driver