aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorreinelt <reinelt@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2003-04-04 06:02:04 +0000
committerreinelt <reinelt@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2003-04-04 06:02:04 +0000
commita5db35ae86f652e520bacfe9c98e92ec3b4b4d66 (patch)
treedeb1bbf2bbb8fb7a9d610520b2d1453c91d0da20 /configure.in
parent91bb12f272ff6901152826d031593c6b12d7d12b (diff)
downloadlcd4linux-a5db35ae86f652e520bacfe9c98e92ec3b4b4d66.tar.gz
[lcd4linux @ 2003-04-04 06:01:59 by reinelt]
new parallel port abstraction scheme git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@187 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 3d052a4..8648538 100644
--- a/configure.in
+++ b/configure.in
@@ -121,6 +121,7 @@ done
AC_MSG_RESULT([done])
RASTER="no"
+PARPORT="no"
if test "$BECKMANNEGLE" = "yes"; then
DRIVERS="$DRIVERS BeckmannEgle.o"
@@ -138,16 +139,19 @@ if test "$CWLINUX" = "yes"; then
fi
if test "$HD44780" = "yes"; then
+ PARPORT="yes"
DRIVERS="$DRIVERS HD44780.o"
AC_DEFINE(WITH_HD44780,1,[junk])
fi
if test "$M50530" = "yes"; then
+ PARPORT="yes"
DRIVERS="$DRIVERS M50530.o"
AC_DEFINE(WITH_M50530,1,[junk])
fi
if test "$T6963" = "yes"; then
+ PARPORT="yes"
DRIVERS="$DRIVERS T6963.o"
AC_DEFINE(WITH_T6963,1,[junk])
fi
@@ -209,16 +213,20 @@ if test "$X11" = "yes"; then
fi
fi
+if test "$DRIVERS" = ""; then
+ AC_MSG_ERROR([You should include at least one driver...])
+fi
+
# Raster.o depends on PPM or PNG
if test "$RASTER" = "yes"; then
DRIVERS="$DRIVERS Raster.o"
fi
-
-if test "$DRIVERS" = ""; then
- AC_MSG_ERROR([You should include at least one driver...])
+# parport driver
+if test "$PARPORT" = "yes"; then
+ DRIVERS="$DRIVERS parport.o"
fi
-
+
AC_SUBST(DRIVERS)
AC_SUBST(DRVLIBS)