aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorreinelt <reinelt@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2000-03-30 16:46:57 +0000
committerreinelt <reinelt@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2000-03-30 16:46:57 +0000
commit668e3626f8770f655164687ca59f1f23b60fb638 (patch)
treefbe96ccf9a9479df23bb99d460772ba9713b1119 /configure.in
parent277c1c4e412df449ea56ffac9f18a14c8b637fc9 (diff)
downloadlcd4linux-668e3626f8770f655164687ca59f1f23b60fb638.tar.gz
[lcd4linux @ 2000-03-30 16:46:57 by reinelt]
configure now handles '--with-x' and '--without-x' correct git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@27 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6e03db7..a184683 100644
--- a/configure.in
+++ b/configure.in
@@ -3,11 +3,18 @@ AC_INIT(lcd4linux.c)
AM_INIT_AUTOMAKE(lcd4linux, 0.95)
dnl Checks for programs.
+AC_PROG_AWK
AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_LN_S
dnl Checks for libraries.
AC_CHECK_LIB(m, log)
+dnl Checks for X11
+AC_PATH_XTRA
+AM_CONDITIONAL(WITH_X, test x$no_x = x)
+
dnl Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(fcntl.h sys/ioctl.h sys/time.h unistd.h)
@@ -17,6 +24,7 @@ AC_HEADER_TIME
dnl Checks for library functions.
AC_PROG_GCC_TRADITIONAL
+AC_TYPE_SIGNAL
AC_CHECK_FUNCS(gettimeofday strdup strerror strstr strtol uname)
AC_OUTPUT(Makefile)