aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorreinelt <reinelt@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2001-09-10 13:55:53 +0000
committerreinelt <reinelt@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2001-09-10 13:55:53 +0000
commit625d3ca196c9d1f99be53e8c262ae68f6ec24ca0 (patch)
treecd36ee97db1d992d09285343ef1c2c08417d7b43 /configure.in
parent3d6eadbe951a6ceefcc01db86eaa34f4800156dc (diff)
downloadlcd4linux-625d3ca196c9d1f99be53e8c262ae68f6ec24ca0.tar.gz
[lcd4linux @ 2001-09-10 13:55:53 by reinelt]
M50530 driver git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@144 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e8a080d..8f6cca0 100644
--- a/configure.in
+++ b/configure.in
@@ -29,7 +29,7 @@ AC_ARG_WITH(
[ drivers may be excluded with 'all,!<driver>',]
[ (try 'all,\!<driver>' if your shell complains...)]
[ possible drivers are:]
- [ BeckmannEgle, CrystalFontz, HD44780,]
+ [ BeckmannEgle, CrystalFontz, HD44780, M50530]
[ MatrixOrbital, PalmPilot, PNG, PPM, X11, Text],
drivers=$withval,
drivers=all
@@ -54,6 +54,7 @@ for driver in $drivers; do
BECKMANNEGLE="yes"
CRYSTALFONTZ="yes"
HD44780="yes"
+ M50530="yes"
MATRIXORBITAL="yes"
PALMPILOT="yes"
PNG="yes"
@@ -69,6 +70,9 @@ for driver in $drivers; do
;;
HD44780)
HD44780=$val
+ ;;
+ M50530)
+ M50530=$val
;;
MatrixOrbital)
MATRIXORBITAL=$val
@@ -119,6 +123,11 @@ if test "$HD44780" = "yes"; then
AC_DEFINE(WITH_HD44780)
fi
+if test "$M50530" = "yes"; then
+ DRIVERS="$DRIVERS M50530.o"
+ AC_DEFINE(WITH_M50530)
+fi
+
if test "$MATRIXORBITAL" = "yes"; then
DRIVERS="$DRIVERS MatrixOrbital.o"
AC_DEFINE(WITH_MATRIXORBITAL)