aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorreinelt <reinelt@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2003-09-29 06:58:37 +0000
committerreinelt <reinelt@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2003-09-29 06:58:37 +0000
commit5abfdf9721cdb83851a15fcec795f59748eb97c6 (patch)
tree219b2b249576d73ba2eedd6a10804e8faaf3ab60 /configure.in
parent0280c32d667a36a5809f2c7a83015a7bc035dce7 (diff)
downloadlcd4linux-5abfdf9721cdb83851a15fcec795f59748eb97c6.tar.gz
[lcd4linux @ 2003-09-29 06:58:36 by reinelt]
new driver for Milford Instruments MI420 by Andy Baxter git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@249 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1888dfb..cdb6d7a 100644
--- a/configure.in
+++ b/configure.in
@@ -43,8 +43,8 @@ AC_ARG_WITH(
[ (try 'all,\!<driver>' if your shell complains...)]
[ possible drivers are:]
[ BeckmannEgle, CrystalFontz, Cwlinux, HD44780,]
- [ M50530, T6963, USBLCD, MatrixOrbital, PalmPilot]
- [ PNG, PPM, X11, Text],
+ [ M50530, T6963, USBLCD, MatrixOrbital,]
+ [ MilfordInstruments, PalmPilot, PNG, PPM, X11, Text],
drivers=$withval,
drivers=all
)
@@ -73,6 +73,7 @@ for driver in $drivers; do
T6963="yes"
USBLCD="yes"
MATRIXORBITAL="yes"
+ MILINST="yes"
PALMPILOT="yes"
PNG="yes"
PPM="yes"
@@ -103,6 +104,9 @@ for driver in $drivers; do
MatrixOrbital)
MATRIXORBITAL=$val
;;
+ MilfordInstruments)
+ MILINST=$val
+ ;;
PalmPilot)
PALMPILOT=$val
;;
@@ -178,6 +182,11 @@ if test "$MATRIXORBITAL" = "yes"; then
AC_DEFINE(WITH_MATRIXORBITAL,1,[junk])
fi
+if test "$MILINST" = "yes"; then
+ DRIVERS="$DRIVERS MilfordInstruments.o"
+ AC_DEFINE(WITH_MILINST,1,[junk])
+fi
+
if test "$PALMPILOT" = "yes"; then
DRIVERS="$DRIVERS PalmPilot.o"
AC_DEFINE(WITH_PALMPILOT,1,[junk])