aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authormichael <michael@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2007-02-25 12:27:26 +0000
committermichael <michael@3ae390bd-cb1e-0410-b409-cd5a39f66f1f>2007-02-25 12:27:26 +0000
commit3c851dd7e04640567ad5a738c43727bb40e9103e (patch)
treed6d80e104d74d26d5d8a67391958e8e362bf5633 /Makefile.am
parent51db519d969ceb3fb82effb49126314ca1d917b0 (diff)
downloadlcd4linux-3c851dd7e04640567ad5a738c43727bb40e9103e.tar.gz
lots of compiler warnings removed, C++-style comments removed, changed struc initialisation from 'field:value' to '.field=value'
git-svn-id: https://ssl.bulix.org/svn/lcd4linux/trunk@771 3ae390bd-cb1e-0410-b409-cd5a39f66f1f
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f7e3e0..9ec7ded 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,6 +13,9 @@ bin_PROGRAMS = lcd4linux
# Fixme: -W should be renamed to -Wextra someday...
AM_CFLAGS = -D_GNU_SOURCE -Wall -W -fno-strict-aliasing
+# use this for lots of warnings
+#AM_CFLAGS = -D_GNU_SOURCE -std=c90 -Wall -W -pedantic -Wno-variadic-macros -fno-strict-aliasing
+
lcd4linux_LDFLAGS =
lcd4linux_LDADD = @DRIVERS@ @PLUGINS@ @DRVLIBS@ @PLUGINLIBS@
lcd4linux_DEPENDENCIES = @DRIVERS@ @PLUGINS@