aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/02-reproducible-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/02-reproducible-build.patch')
-rw-r--r--debian/patches/02-reproducible-build.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/patches/02-reproducible-build.patch b/debian/patches/02-reproducible-build.patch
new file mode 100644
index 0000000..f583e36
--- /dev/null
+++ b/debian/patches/02-reproducible-build.patch
@@ -0,0 +1,14 @@
+Author: Reiner Herrmann <reiner@reiner-h.de>
+Description: Sort object files for deterministic linking order
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -21,7 +21,7 @@
+ MAIN = @PACKAGE_NAME@.c
+ HEADERS = $(wildcard *.h)
+ PURESRC = $(filter-out $(MAIN),$(wildcard *.c))
+-OBJS = $(PURESRC:.c=.o)
++OBJS = $(sort $(PURESRC:.c=.o))
+
+ %.o: %.c $(HEADERS)
+ @echo ' CC ' $<