aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/02-honour-CC.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/02-honour-CC.patch')
-rw-r--r--debian/patches/02-honour-CC.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/patches/02-honour-CC.patch b/debian/patches/02-honour-CC.patch
new file mode 100644
index 0000000..519046b
--- /dev/null
+++ b/debian/patches/02-honour-CC.patch
@@ -0,0 +1,19 @@
+From: Helmut Grohne <helmut@subdivi.de>
+Subject: honour the CC variable from configure
+
+A ?= assignment to CC is a noop, because CC has a make default of "cc". This
+breaks e.g. cross compilation.
+
+Index: wavemon-0.8.1/Makefile.in
+===================================================================
+--- wavemon-0.8.1.orig/Makefile.in
++++ wavemon-0.8.1/Makefile.in
+@@ -8,7 +8,7 @@
+ exec_perms = 0755
+ install-suid-root: exec_perms = 4755
+
+-CC ?= @CC@
++CC = @CC@
+ CFLAGS ?= @CFLAGS@ @LIBNL3_CFLAGS@
+ CPPFLAGS ?= @CPPFLAGS@
+ LDFLAGS ?= @LDFLAGS@