aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 8 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 8d6cbce..e50c986 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.64)
-AC_INIT([wavemon], [0.7.5], [gerrit@erg.abdn.ac.uk], [wavemon-current],
- [http://eden-feed.erg.abdn.ac.uk/wavemon])
+AC_INIT([wavemon], [0.7.6], [gerrit@erg.abdn.ac.uk], [wavemon-current],
+ [http://www.erg.abdn.ac.uk/ergcms/wavemon/])
# Variables
@@ -28,7 +28,7 @@ AC_PROG_INSTALL
AC_HEADER_STDC
AC_HEADER_TIME
AC_CHECK_HEADERS([ncurses.h fcntl.h netdb.h sys/ioctl.h sys/time.h unistd.h\
- net/if_arp.h netinet/ether.h net/ethernet.h],
+ net/if_arp.h netinet/ether.h net/ethernet.h pthread.h],
[], [AC_MSG_ERROR($ac_header not found)])
# linux/if.h needs 'struct sockaddr'
@@ -53,18 +53,14 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
AC_HEADER_STDBOOL
# Tests involving libraries
-AC_CHECK_LIB([m], [pow])
-AC_CHECK_LIB([ncurses], [waddstr])
+AC_CHECK_LIB([m], [pow], [], [AC_MSG_ERROR(math library not found)])
+AC_CHECK_LIB([ncurses], [waddstr], [], [AC_MSG_ERROR(ncurses library not found)])
+AC_CHECK_LIB([pthread], [pthread_create], [CFLAGS="$CFLAGS -pthread"],
+ [AC_MSG_ERROR(pthread library not found)])
AC_CHECK_LIB([cap], [cap_get_flag])
-
# Testing library functions
-AC_CHECK_FUNCS([modf log10 gettimeofday \
- memmove memset strdup \
- strchr strspn strcspn \
- strcasecmp strncasecmp \
- strtol \
- ether_ntohost], [],
+AC_CHECK_FUNCS([gettimeofday ether_ntohost], [],
[AC_MSG_ERROR(function '$ac_func' not supported)])
# Checks for typedefs, structures, and compiler characteristics.