aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 11 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 323b96c..c70e825 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,19 +1,12 @@
dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.64)
-AC_INIT([wavemon], [0.8.2], [https://github.com/uoaerg/wavemon], [wavemon-current],
+AC_INIT([wavemon], [0.9.1], [https://github.com/uoaerg/wavemon], [wavemon-current],
[https://github.com/uoaerg/wavemon])
# Variables
AC_CONFIG_AUX_DIR([config])
AC_CONFIG_FILES([Makefile])
-# allow BUILD_DATE to be externally set for build reproducibility
-if test "$BUILD_DATE"; then
- AC_DEFINE_UNQUOTED(BUILD_DATE, ["$BUILD_DATE"])
-else
- AC_DEFINE_UNQUOTED([BUILD_DATE], ["`/bin/date`"],
- [date wavemon was last configured and built])
-fi
CFLAGS="-O2 -Wall"
@@ -62,7 +55,16 @@ AC_CHECK_LIB([m], [pow], [], [AC_MSG_ERROR(math library not found)]
AC_CHECK_LIB([ncurses], [waddstr], [], [AC_MSG_ERROR(ncurses library not found)])
AC_CHECK_LIB([pthread], [pthread_create], [CFLAGS="$CFLAGS -pthread"],
[AC_MSG_ERROR(pthread library not found)])
-AC_CHECK_LIB([cap], [cap_get_flag])
+
+# libcap - allow to disable, since e.g. OpenWrt does not use it.
+# https://github.com/uoaerg/wavemon/issues/54
+AC_ARG_WITH([libcap],
+ [AS_HELP_STRING([--without-libcap],
+ [disable support for libcap])],
+ [],
+ [with_libcap=yes])
+
+AS_IF([test "x$with_libcap" != xno], AC_CHECK_LIB([cap], [cap_get_flag]))
# Testing library functions
AC_CHECK_FUNCS([gettimeofday ether_ntohost], [],