aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-02-05 19:04:33 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2012-02-05 19:04:33 +0000
commitf3410da7f0bd208a5f2d792131b215454e782e93 (patch)
tree6e79c9acde383b91f5f21eb3a72f33e9c7fbbfce /configure.ac
parent03dfbc2efa31d3c4fd7e576111883ea488e3e179 (diff)
downloadwavemon-f3410da7f0bd208a5f2d792131b215454e782e93.tar.gz
Imported Upstream version 0.7.3upstream/0.7.3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b66b40b..62666fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.50)
-AC_INIT([wavemon], [0.6.10], [gerrit@erg.abdn.ac.uk], [wavemon-current])
+AC_PREREQ(2.64)
+AC_INIT([wavemon], [0.7.3], [gerrit@erg.abdn.ac.uk], [wavemon-current],
+ [http://eden-feed.erg.abdn.ac.uk/wavemon])
# Variables
@@ -41,11 +42,20 @@ AC_CHECK_HEADERS([sys/socket.h linux/if.h linux/wireless.h], [],
# include <linux/if.h>
#endif
])
+# require minimum version of the wireless extensions
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
+ [#include <sys/socket.h>
+ #include <linux/wireless.h>
+ #if WIRELESS_EXT < 18
+ #error "Need minimum version WIRELESS_EXT = 18"
+ #endif])],[],
+ [AC_MSG_FAILURE([linux/wireless.h is too old, need WE >= 18])])
AC_HEADER_STDBOOL
# Tests involving libraries
AC_CHECK_LIB([m], [pow])
AC_CHECK_LIB([ncurses], [waddstr])
+AC_CHECK_LIB([cap], [cap_get_flag])
# Testing library functions