aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2020-07-29 23:11:46 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2020-07-29 23:11:46 +0100
commit612e6fdfa43ac716a2431d695de842f7127c12d0 (patch)
tree58532da4c219499547e0ab5554d78ea112eea466 /configure.ac
parent818f5500fa11d5bf57c5542b20beb94d6f0dda6e (diff)
parent8deb3660926fe8278948b898b9c1b772eed2e61e (diff)
downloadwavemon-612e6fdfa43ac716a2431d695de842f7127c12d0.tar.gz
Update upstream source from tag 'upstream/0.9.1'
Update to upstream version '0.9.1' with Debian dir 559193b433abdd46788bc66e02edda248b928278
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 11 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 323b96c..c70e825 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,19 +1,12 @@
dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.64)
-AC_INIT([wavemon], [0.8.2], [https://github.com/uoaerg/wavemon], [wavemon-current],
+AC_INIT([wavemon], [0.9.1], [https://github.com/uoaerg/wavemon], [wavemon-current],
[https://github.com/uoaerg/wavemon])
# Variables
AC_CONFIG_AUX_DIR([config])
AC_CONFIG_FILES([Makefile])
-# allow BUILD_DATE to be externally set for build reproducibility
-if test "$BUILD_DATE"; then
- AC_DEFINE_UNQUOTED(BUILD_DATE, ["$BUILD_DATE"])
-else
- AC_DEFINE_UNQUOTED([BUILD_DATE], ["`/bin/date`"],
- [date wavemon was last configured and built])
-fi
CFLAGS="-O2 -Wall"
@@ -62,7 +55,16 @@ AC_CHECK_LIB([m], [pow], [], [AC_MSG_ERROR(math library not found)]
AC_CHECK_LIB([ncurses], [waddstr], [], [AC_MSG_ERROR(ncurses library not found)])
AC_CHECK_LIB([pthread], [pthread_create], [CFLAGS="$CFLAGS -pthread"],
[AC_MSG_ERROR(pthread library not found)])
-AC_CHECK_LIB([cap], [cap_get_flag])
+
+# libcap - allow to disable, since e.g. OpenWrt does not use it.
+# https://github.com/uoaerg/wavemon/issues/54
+AC_ARG_WITH([libcap],
+ [AS_HELP_STRING([--without-libcap],
+ [disable support for libcap])],
+ [],
+ [with_libcap=yes])
+
+AS_IF([test "x$with_libcap" != xno], AC_CHECK_LIB([cap], [cap_get_flag]))
# Testing library functions
AC_CHECK_FUNCS([gettimeofday ether_ntohost], [],