aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2009-12-11 22:10:25 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2012-02-05 19:03:25 +0000
commitc93ad1a4ef2625ffb849b8868fe32f930594ac70 (patch)
tree944a0695cd44729cb14741ffa71b94d902e43d56
parent03dfbc2efa31d3c4fd7e576111883ea488e3e179 (diff)
downloadwavemon-c93ad1a4ef2625ffb849b8868fe32f930594ac70.tar.gz
Imported Debian patch 0.6.10-1debian/0.6.10-1
-rw-r--r--Makefile.in25
-rw-r--r--debian/changelog135
-rw-r--r--debian/compat1
-rw-r--r--debian/control18
-rw-r--r--debian/copyright33
-rw-r--r--debian/dirs3
-rw-r--r--debian/menu3
-rw-r--r--debian/patches/11_wavemonrc_section.diff8
-rw-r--r--debian/patches/12_dont_install_DOCS.diff19
-rwxr-xr-xdebian/rules11
10 files changed, 241 insertions, 15 deletions
diff --git a/Makefile.in b/Makefile.in
index 7c81ad5..3bbc253 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -34,34 +34,29 @@ config.status: configure
configure: configure.ac
autoconf
-tags: $(MAIN) $(PURESRC) $(HEADERS)
+tags: $(wildcard *[ch])
ctags $^ > $@
-.PHONY: all install uninstall clean distclean
+.PHONY: install uninstall clean distclean
-install: install-binaries install-docs
-
-install-binaries: all
+install: wavemon wavemon.1 wavemonrc.5 $(DOCS)
$(INSTALL) -m 0755 -d $(DESTDIR)$(bindir)
- $(INSTALL) -m 0755 @PACKAGE_NAME@ $(DESTDIR)$(bindir)
-
-install-docs: @PACKAGE_NAME@.1 @PACKAGE_NAME@rc.5 $(DOCS)
+ $(INSTALL) -m 0755 wavemon $(DESTDIR)$(bindir)
$(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man1
- $(INSTALL) -m 0644 @PACKAGE_NAME@.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 0644 wavemon.1 $(DESTDIR)$(mandir)/man1
$(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man5
- $(INSTALL) -m 0644 @PACKAGE_NAME@rc.5 $(DESTDIR)$(mandir)/man5
+ $(INSTALL) -m 0644 wavemonrc.5 $(DESTDIR)$(mandir)/man5
$(INSTALL) -m 0755 -d $(DESTDIR)$(datadir)
$(INSTALL) -m 0644 $(DOCS) $(DESTDIR)$(datadir)
uninstall:
- @$(RM) $(bindir)/@PACKAGE_NAME@
- @$(RM) $(mandir)/man1/@PACKAGE_NAME@.1
- @$(RM) $(mandir)/man5/@PACKAGE_NAME@rc.5
+ @$(RM) $(bindir)/wavemon
+ @$(RM) $(mandir)/man1/wavemon.1
+ @$(RM) $(mandir)/man5/wavemonrc.5
@$(RM) -r $(datadir)
clean:
- @$(RM) *.o *~ tags @PACKAGE_NAME@
+ @$(RM) *.o *.doc wavemon tags
distclean: uninstall clean
@$(RM) config.status config.log config.cache Makefile
- @$(RM) -r autom4te.cache
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..0ad24a9
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,135 @@
+wavemon (0.6.10-1) unstable; urgency=low
+
+ * New upstream release (closes: #560728)
+
+ -- Rene Engelhard <rene@debian.org> Fri, 11 Dec 2009 22:10:25 +0100
+
+wavemon (0.6.7-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Rene Engelhard <rene@debian.org> Fri, 14 Aug 2009 16:09:34 +0200
+
+wavemon (0.6.6-1) experimental; urgency=low
+
+ * New upstream release
+
+ -- Rene Engelhard <rene@debian.org> Sun, 07 Jun 2009 22:22:33 +0200
+
+wavemon (0.6-1) experimental; urgency=low
+
+ * New upstream release
+ - contains newer config.* (closes: #357956)
+
+ -- Rene Engelhard <rene@debian.org> Fri, 17 Apr 2009 00:37:20 +0200
+
+wavemon (0.5-1) unstable; urgency=low
+
+ * New upstream release
+ - fixes display of signal and noise levels when specifying interface
+ (closes: #444773)
+ - does not crash anymore when window is too small (closes: #201418)
+ - allows overriding of settings in .wavemonrc on command line
+ (closes: #258784)
+ * clean debian/patches except 11_wavemonrc_section.diff
+ * add ${misc:Depends}
+ * fix for new menu section
+
+ -- Rene Engelhard <rene@debian.org> Fri, 17 Apr 2009 00:36:22 +0200
+
+wavemon (0.4.0b-11) unstable; urgency=low
+
+ * build-depend on linux-libc-dev as first alternative. Fixes the FTBFS
+ on the ia64 buildd...
+ * fix wavemonrc(5)'s section
+
+ -- Rene Engelhard <rene@debian.org> Mon, 02 Jul 2007 14:06:09 +0200
+
+wavemon (0.4.0b-10) unstable; urgency=low
+
+ * add patch from Paul Martin fixing UTF-8 locale (closes: #229106)
+ * add patch from Paul Martin fixing reading dBM values (closes: #426300)
+ * make the code #include <stdlib.h> where needed
+
+ -- Rene Engelhard <rene@debian.org> Sun, 17 Jun 2007 13:04:05 +0100
+
+wavemon (0.4.0b-9) unstable; urgency=low
+
+ * rebuild against new linux-kernel-headers (closes: #328442)
+
+ -- Rene Engelhard <rene@debian.org> Fri, 2 Dec 2005 09:33:40 +0100
+
+wavemon (0.4.0b-8) unstable; urgency=low
+
+ * fix build with gcc-4.0 (closes: #297247), thanks Andreas Jochens
+
+ -- Rene Engelhard <rene@debian.org> Tue, 26 Jul 2005 22:38:24 +0200
+
+wavemon (0.4.0b-7) unstable; urgency=low
+
+ * add patch for fixing build with gcc-3.4, thanks Andreas Jochens
+ (closes: #264264)
+
+ -- Rene Engelhard <rene@debian.org> Tue, 10 Aug 2004 00:18:16 +0200
+
+wavemon (0.4.0b-6) unstable; urgency=low
+
+ * fix aplist_scr.c to display MAC adresses actuallx XX:XX:...,
+ thanks Sebastian 'yath' Schmidt for the patch (closes: #233103)
+
+ -- Rene Engelhard <rene@debian.org> Tue, 17 Feb 2004 00:36:49 +0100
+
+wavemon (0.4.0b-5) unstable; urgency=medium
+
+ * rebuild with linux-kernel-headers and thefore newer
+ linux/wireless.h (closes: #223660)
+
+ -- Rene Engelhard <rene@debian.org> Sun, 14 Dec 2003 20:47:17 +0100
+
+wavemon (0.4.0b-4) unstable; urgency=high
+
+ * add patches from Lennart Poettering <mzqrooht@itaparica.org>; thanks:
+ - make wavemon show WEP keyinfo correctly if containing
+ bytes > 0x7F (closes: #205907)
+ - x show ESSIDs and Nicks > 31 chars correctly
+ x draw its gauges even on terminals having more than 127 colums
+ (addresses: #205915)
+ * Standards-Version: 3.6.1 (no changes needed)
+
+ -- Rene Engelhard <rene@debian.org> Fri, 5 Sep 2003 20:14:05 +0200
+
+wavemon (0.4.0b-3) unstable; urgency=low
+
+ * The "Argh-I-thought-cdbs-would-depend-on-debhelper" release.
+ * add Build-Depends: on debhelper (>= 4.1.0) (as the docs say...)
+ (closes: #204024)
+
+ -- Rene Engelhard <rene@debian.org> Mon, 4 Aug 2003 02:01:07 +0200
+
+wavemon (0.4.0b-2) unstable; urgency=low
+
+ * The "OK-let's-try-cdbs-out" release.
+ * New maintainer; thanks Joey
+ * move to cdbs
+ * call exit(0) instead of exit() in wavemon.c (closes: #195174)
+ * cleans right (closes: #199004)
+ * remove the NMU disclaimer...
+ * Standards-Version: 3.6.0
+
+ -- Rene Engelhard <rene@debian.org> Fri, 1 Aug 2003 05:47:33 +0200
+
+wavemon (0.4.0b-1) unstable; urgency=low
+
+ * Added a disclaimer for those people who plan to NMU this package
+ * New upstream version (closes: Bug##137040)
+ * Applied patches from Vincent Danjean <Vincent.Danjean@ens-lyon.org>,
+ thanks a lot.
+ * Updated Standards-Version
+
+ -- Martin Schulze <joey@infodrom.org> Mon, 14 Apr 2003 19:29:30 +0200
+
+wavemon (0.3.3-1) unstable; urgency=low
+
+ * Initial packaging
+
+ -- Martin Schulze <joey@finlandia.infodrom.north.de> Sat, 8 Dec 2001 10:38:31 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..b9da355
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,18 @@
+Source: wavemon
+Section: net
+Priority: extra
+Maintainer: Rene Engelhard <rene@debian.org>
+Build-Depends: cdbs, libncurses5-dev, debhelper (>= 4.1.0), linux-libc-dev | linux-kernel-headers (>= 2.6.13+0rc3)
+Standards-Version: 3.6.1
+Homepage: http://eden-feed.erg.abdn.ac.uk/wavemon
+
+Package: wavemon
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Wireless Device Monitoring Application
+ Wavemon allows you to watch signal and noise levels, packet
+ statistics, device configuration and network parameters of your
+ wireless network hardware. It has currently only been tested with
+ the Lucent Orinoco series of cards, although it *should* work (though
+ with varying features) with all devices supported by the wireless
+ kernel extensions by Jean Tourrilhes.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..9002a4c
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,33 @@
+This is the Debian GNU/Linux prepackaged version of wavemon, a monitor
+application for wireless hardware.
+
+This package was put together by Martin Schulze <joey@debian.org>,
+from sources obtained from:
+
+ http://www.wavemage.com/wavemon-current.tar.gz
+
+Currently maintained by Rene Engelhard <rene@debian.org>
+
+wavemon is distributed under the terms of the GNU General Public License.
+
+ Copyright (c) 2001-2002 Jan Morgenstern <jan@jm-music.de>
+ Copyright (c) 2009 Gerrit Renker <gerrit@erg.abdn.ac.uk>
+
+ * wavemon is free software; you can redistribute it and/or modify it under
+ * the terms of the GNU General Public License as published by the Free
+ * Software Foundation; either version 2, or (at your option) any later
+ * version.
+ *
+ * wavemon is distributed in the hope that it will be useful, but WITHOUT ANY
+ * WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+ * FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
+ * details.
+ *
+ * You should have received a copy of the GNU General Public License along
+ * with wavemon; see the file COPYING. If not, write to the Free Software
+ * Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+On Debian GNU/Linux systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL-2'.
+
+If you have bug reports or suggestions, please contact Gerrit.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..603bd4d
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,3 @@
+usr/share/man/man1
+usr/share/man/man5
+usr/bin
diff --git a/debian/menu b/debian/menu
new file mode 100644
index 0000000..2aa2d58
--- /dev/null
+++ b/debian/menu
@@ -0,0 +1,3 @@
+?package(wavemon):needs="text" section="Applications/Network/Monitoring" \
+ title="wavemon" \
+ command="/usr/bin/wavemon"
diff --git a/debian/patches/11_wavemonrc_section.diff b/debian/patches/11_wavemonrc_section.diff
new file mode 100644
index 0000000..af16416
--- /dev/null
+++ b/debian/patches/11_wavemonrc_section.diff
@@ -0,0 +1,8 @@
+--- wavemonrc.5-old 2009-04-15 22:44:52.000000000 +0200
++++ wavemonrc.5 2009-04-15 22:44:58.000000000 +0200
+@@ -1,4 +1,4 @@
+-.TH WAVEMON 1 "JANUARY 2009" Linux "User Manuals"
++.TH WAVEMON 5 "JANUARY 2009" Linux "User Manuals"
+ .SH NAME
+ wavemonrc \- wavemon configuration file
+ .SH SYNOPSIS
diff --git a/debian/patches/12_dont_install_DOCS.diff b/debian/patches/12_dont_install_DOCS.diff
new file mode 100644
index 0000000..1a75a40
--- /dev/null
+++ b/debian/patches/12_dont_install_DOCS.diff
@@ -0,0 +1,19 @@
+--- Makefile.in-old 2009-12-11 22:09:29.000000000 +0100
++++ Makefile.in 2009-12-11 22:10:04.000000000 +0100
+@@ -39,15 +39,13 @@
+
+ .PHONY: install uninstall clean distclean
+
+-install: wavemon wavemon.1 wavemonrc.5 $(DOCS)
++install: wavemon wavemon.1 wavemonrc.5
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(bindir)
+ $(INSTALL) -m 0755 wavemon $(DESTDIR)$(bindir)
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 0644 wavemon.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(mandir)/man5
+ $(INSTALL) -m 0644 wavemonrc.5 $(DESTDIR)$(mandir)/man5
+- $(INSTALL) -m 0755 -d $(DESTDIR)$(datadir)
+- $(INSTALL) -m 0644 $(DOCS) $(DESTDIR)$(datadir)
+
+ uninstall:
+ @$(RM) $(bindir)/wavemon
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1ff7b01
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+
+DEB_MAKE_INSTALL_TARGET=install DESTDIR=`pwd`/debian/wavemon
+
+clean::
+ rm -f *.o wavemon
+ rm -f config.status config.log defs.h config.cache Makefile