aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-03-07 22:33:59 +0000
committerJonathan McCrohan <jmccrohan@gmail.com>2012-03-07 23:24:29 +0000
commitcf27f1f979be18b4416e9b00bc53dd748f6c347c (patch)
tree1af3c7b4721c94bb4a94839431f2f49d666d790d /debian
parent8983c0b79b93d672adffbf823bcd50654a6e87de (diff)
downloadnyancat-cf27f1f979be18b4416e9b00bc53dd748f6c347c.tar.gz
Fix wonky patch
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/01-nyancat-make-install.patch28
1 files changed, 19 insertions, 9 deletions
diff --git a/debian/patches/01-nyancat-make-install.patch b/debian/patches/01-nyancat-make-install.patch
index 6697860..00b6062 100644
--- a/debian/patches/01-nyancat-make-install.patch
+++ b/debian/patches/01-nyancat-make-install.patch
@@ -1,8 +1,17 @@
-diff --git Makefile Makefile
-index 9ac517f..862f69b 100644
---- Makefile
-+++ Makefile
-@@ -3,33 +3,12 @@ version = 0.1
+diff --git a/Makefile b/Makefile
+index 9ac517f..318bce4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,35 +1,22 @@
++prefix = /usr
++exec_prefix = ${prefix}
++
++bindir = ${exec_prefix}/bin
++datarootdir = $(prefix)/share
++mandir = ${datarootdir}/man
++
+ package = nyancat
+ version = 0.1
tarname = $(package)
distdir = $(tarname)-$(version)
@@ -10,12 +19,13 @@ index 9ac517f..862f69b 100644
- cd src && $(MAKE) $@
-
-dist: $(distdir).tar.gz
--
++SRCDIR = src
++INSTALL = /usr/bin/install -c
+
-$(distdir).tar.gz: $(distdir)
- tar chof - $(distdir) | gzip -9 -c > $@
- rm -rf $(distdir)
-+SRCDIR = src
-
+-
-$(distdir): FORCE
- mkdir -p $(distdir)/src
- cp Makefile $(distdir)
@@ -38,7 +48,7 @@ index 9ac517f..862f69b 100644
- rm -rf $(distdir)
- @echo "*** Package $(distdir).tar.gz is ready for distribution."
+install :
-+ install -m 0755 $(SRCDIR)/nyancat /usr/bin/nyancat
++ $(INSTALL) -Dm 0755 $(SRCDIR)/$(package) $(DESTDIR)$(bindir)/$(package)
-.PHONY: FORCE all clean check dist distcheck
+.PHONY: all clean check install