aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2013-07-01 00:31:39 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2013-07-01 00:31:39 +0100
commitc69da2696f87d6b87139c92cb579e837288310ee (patch)
treec355f7f97309adf7d3d53ebe829da3ed3dc58293
parent081445aa23df71007f42ded9932874e345647dbd (diff)
parent41a9321a47b971225e0a46478e9906c9cc1c097c (diff)
downloadnyancat-c69da2696f87d6b87139c92cb579e837288310ee.tar.gz
Merge tag 'upstream/1.2'
Upstream version 1.2
-rw-r--r--CHANGELOG5
-rw-r--r--Makefile2
-rw-r--r--src/animation.c (renamed from src/animation.h)0
-rw-r--r--src/nyancat.c28
4 files changed, 9 insertions, 26 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 56973f3..a046b0f 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,8 @@
+1.2 (marked on 2013-05-20)
+ * Remove toaruos legacy support
+ * May possibly have fixed misidentification on GitHub
+ * Other minor fixes
+
1.1 (tagged on 2013-01-28)
* Support the Suckless terminal
* Support building for とあるOS
diff --git a/Makefile b/Makefile
index 4a7575d..06bd4fe 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
package = nyancat
-version = 1.1
+version = 1.2
tarname = $(package)
distdir = $(tarname)-$(version)
diff --git a/src/animation.h b/src/animation.c
index ad1aae4..ad1aae4 100644
--- a/src/animation.h
+++ b/src/animation.c
diff --git a/src/nyancat.c b/src/nyancat.c
index 44bdf06..dd3288f 100644
--- a/src/nyancat.c
+++ b/src/nyancat.c
@@ -60,26 +60,15 @@
#include <setjmp.h>
#include <getopt.h>
-#ifdef __toaru__
-
-#include <syscall.h>
-
-DEFN_SYSCALL2(nanosleep, 46, unsigned long, unsigned long);
-
-int usleep(useconds_t time) {
- syscall_nanosleep(0, time / 10000);
-}
-
-#else
#include <sys/ioctl.h>
-#endif
#ifndef TIOCGWINSZ
#include <termios.h>
+#endif
+
#ifdef ECHO
#undef ECHO
#endif
-#endif
/*
* telnet.h contains some #defines for the various
@@ -93,7 +82,7 @@ int usleep(useconds_t time) {
* The animation frames are stored separately in
* this header so they don't clutter the core source
*/
-#include "animation.h"
+#include "animation.c"
/*
* Color palette to use for final output
@@ -531,20 +520,9 @@ int main(int argc, char ** argv) {
}
/* Also get the number of columns */
-#ifdef __toaru__
- if (strstr(term, "toaru")) {
- printf("\033[1003z");
- fflush(stdout);
- int height;
- scanf("%d,%d", &terminal_width, &height);
- } else {
- terminal_width = 80; /* better safe than sorry */
- }
-#else
struct winsize w;
ioctl(0, TIOCGWINSZ, &w);
terminal_width = w.ws_col;
-#endif
}
/* Convert the entire terminal string to lower case */