aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan McCrohan <jmccrohan@gmail.com>2012-05-25 00:45:52 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2012-06-05 02:40:06 +0100
commit5b8566eb55d1ae870bc9887fdde6b44d5f9bf381 (patch)
treeeab5df91105bd5d9944966e21c606ffb16e13955
parent4a915274f2ef8986a4e86be38991e8e2f6164e6b (diff)
parent99dc3100b9df5dc2f6c8484d104b6a7fd233ee10 (diff)
downloadnyancat-5b8566eb55d1ae870bc9887fdde6b44d5f9bf381.tar.gz
New upstream snapshot
-rw-r--r--Makefile2
-rw-r--r--nyancat.164
-rw-r--r--src/Makefile2
3 files changed, 66 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index e45440e..0e198b8 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
package = nyancat
-version = 0.1
+version = 1.0
tarname = $(package)
distdir = $(tarname)-$(version)
diff --git a/nyancat.1 b/nyancat.1
new file mode 100644
index 0000000..af289f9
--- /dev/null
+++ b/nyancat.1
@@ -0,0 +1,64 @@
+.TH NYANCAT 1 "May, 2012"
+.SH NAME
+nyancat \- terminal-based Pop Tart Cat animation
+.SH SYNOPSIS
+.B nyancat [ -hitn ] [-f frames]
+.SH DESCRIPTION
+.B nyancat
+is an animated, color, ANSI-text program that renders a loop of the
+classic Nyan Cat animation.
+.PP
+nyancat makes use of various ANSI escape sequences to render color, or in the case
+of a VT220, simply dumps text to the screen.
+.SH OPTIONS
+.TP
+.B \-i, --intro
+Show introduction / about information on startup.
+.TP
+.B \-t, --telnet
+Enable telnet mode.
+.TP
+.B \-n, --no-counter
+Do not display the timer.
+.TP
+.B \-s, --no-title
+Do not set the titlebar text.
+.TP
+.B \-e, --no-clear
+Do not clear the display between frames.
+.TP
+.B \-f, --frames
+Display the requested number of frames, then quit.
+.TP
+.B \-r, --min-rows
+Crop the animation from the top.
+.TP
+.B \-R, --max-rows
+Crop the animation from the bottom.
+.TP
+.B \-c, --min-cols
+Crop the animation from the left.
+.TP
+.B \-C, --max-cols
+Crop the animation from the right.
+.TP
+.B \-W, --width
+Crop the animation to the given width.
+.TP
+.B \-H, --height
+Crop the animation to the given height.
+.TP
+.B \-h, --help
+Show help message and exit.
+.SH HOMEPAGE
+.PP
+.B Homepage:
+http://miku.acm.uiuc.edu/
+.PP
+.B Repository:
+https://github.com/klange/nyancat
+.SH AUTHOR
+nyancat was written by Kevin Lange.
+.PP
+This manual page was written by Jonathan McCrohan <jmccrohan@gmail.com>,
+for the Debian project (and may be used by others).
diff --git a/src/Makefile b/src/Makefile
index 1701c11..c77c6cb 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -3,7 +3,7 @@ OBJECTS = nyancat.o
all: nyancat
nyancat: $(OBJECTS)
- $(CC) $(LFLAGS) $(OBJECTS) -o $@
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(OBJECTS) -o $@
clean:
-rm -f $(OBJECTS) nyancat