aboutsummaryrefslogtreecommitdiffstats
path: root/util/ttusb_dec_reset/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'util/ttusb_dec_reset/Makefile')
-rw-r--r--util/ttusb_dec_reset/Makefile28
1 files changed, 15 insertions, 13 deletions
diff --git a/util/ttusb_dec_reset/Makefile b/util/ttusb_dec_reset/Makefile
index cde7de5..b2ca852 100644
--- a/util/ttusb_dec_reset/Makefile
+++ b/util/ttusb_dec_reset/Makefile
@@ -1,17 +1,19 @@
-CC = gcc
-RM = rm -f
-CFLAGS = -g -Wall -O2
-LFLAGS = -g -Wall
-LDFLAGS = -lusb
+# Makefile for linuxtv.org dvb-apps/util/ttusb_dec_reset
-OBJS = ttusb_dec_reset.o
-TARGET = ttusb_dec_reset
+binaries = ttusb_dec_reset
-$(TARGET): $(OBJS)
- $(CC) $(LFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJS)
+ifneq ($(realpath $(binaries)),)
+inst_bin = $(binaries)
+endif
-.c.o:
- $(CC) $(CFLAGS) -c $< -o $@
+LDLIBS += -lusb
-clean:
- $(RM) *.o $(TARGET)
+.PHONY: all
+
+ifeq ($(ttusb_dec_reset),1)
+all: $(binaries)
+else
+all: clean
+endif
+
+include ../../Make.rules