aboutsummaryrefslogtreecommitdiffstats
path: root/util/szap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'util/szap/Makefile')
-rw-r--r--util/szap/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/util/szap/Makefile b/util/szap/Makefile
index 48d7149..837e989 100644
--- a/util/szap/Makefile
+++ b/util/szap/Makefile
@@ -1,5 +1,11 @@
# Makefile for linuxtv.org dvb-apps/util/szap
+# get DVB API version
+VERSION_FILE := "/usr/include/linux/dvb/version.h"
+
+DVB_API_MAJOR := $(word 3, $(shell grep -m1 "DVB_API_VERSION" $(VERSION_FILE)) )
+DVB_API_MINOR := $(word 3, $(shell grep -m1 "DVB_API_VERSION_MINOR" $(VERSION_FILE)) )
+
objects = lnb.o util.o
binaries = azap \
@@ -12,6 +18,7 @@ inst_bin = $(binaries)
.PHONY: all
all: $(binaries)
+$(info DVB API is $(DVB_API_MAJOR).$(DVB_API_MINOR))
$(binaries): $(objects)