aboutsummaryrefslogtreecommitdiffstats
path: root/util/dvbnet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'util/dvbnet/Makefile')
-rw-r--r--util/dvbnet/Makefile32
1 files changed, 9 insertions, 23 deletions
diff --git a/util/dvbnet/Makefile b/util/dvbnet/Makefile
index 187dee2..c9ebab9 100644
--- a/util/dvbnet/Makefile
+++ b/util/dvbnet/Makefile
@@ -1,29 +1,15 @@
+# Makefile for linuxtv.org dvb-apps/util/dvbnet
-CC = gcc
-CFLAGS = -g -O2 -MD -Wall -I. -I../../include
-LFLAGS =
+binaries = dvbnet
-OBJS = dvbnet.o
-TARGET = dvbnet
-DESTDIR = /usr/local/bin/
+inst_bin = $(binaries)
-all: version.h $(TARGET)
+CPPFLAGS += -I../../lib
+LDFLAGS += -L../../lib/libdvbapi
+LDLIBS += -ldvbapi
-.c.o:
- $(CC) $(CFLAGS) -c $< -o $@
+.PHONY: all
-$(TARGET): $(OBJS)
- $(CC) -o $@ $(OBJS) $(LFLAGS)
-
-version.h:
- printf '#define VERSION_INFO "%s (Build %s)"\n' \
- "`cat $@.in`" "`date +'%a %b %d %X %Y'`" > $@
-
-install: all
- install -m 755 $(TARGET) $(DESTDIR)
-
-clean:
- rm -f $(TARGET) $(OBJS) version.h core* *~ *.d
-
--include $(wildcard *.d) dummy
+all: $(binaries)
+include ../../Make.rules