aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile')
-rw-r--r--test/Makefile64
1 files changed, 34 insertions, 30 deletions
diff --git a/test/Makefile b/test/Makefile
index ddff9ab..30cb9e3 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -1,37 +1,41 @@
-# Makefile for Linux DVB API Version 3 test programs
+# Makefile for linuxtv.org dvb-apps/test
-CC = gcc
-CFLAGS = -g -O2 -W -Wall -I../include
+objects = hex_dump.o lnb.o
-TARGETS = \
- diseqc \
- set22k \
- sendburst \
- setvoltage \
- setpid \
- video \
- test_sections \
- test_sec_ne \
- test_pes \
- test_dvr \
- test_dvr_play \
- test_tt \
- test_av \
- test_av_play \
- test_vevent \
- test_stc \
- test_stillimage
+binaries = diseqc \
+ sendburst \
+ set22k \
+ setpid \
+ setvoltage \
+ test_av \
+ test_av_play \
+ test_dvr \
+ test_dvr_play \
+ test_pes \
+ test_sec_ne \
+ test_sections \
+ test_stc \
+ test_stillimage \
+ test_tt \
+ test_vevent \
+ evtest \
+ video \
+ szap2
-# test \
-# test_audio \
-# test_front \
-# test_switch \
-# test_video \
+.PHONY: all
-all: $(TARGETS)
+all: $(binaries)
+ make -C libdvbcfg $@
+ make -C libdvben50221 $@
+ make -C libesg $@
+ make -C libucsi $@
-test_sections test_sec_ne test_pes test_tt: hex_dump.o
+$(binaries): $(objects)
-clean:
- rm -f $(TARGETS) *.o
+clean::
+ make -C libdvbcfg $@
+ make -C libdvben50221 $@
+ make -C libesg $@
+ make -C libucsi $@
+include ../Make.rules