aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile')
-rw-r--r--test/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/test/Makefile b/test/Makefile
new file mode 100644
index 0000000..ddff9ab
--- /dev/null
+++ b/test/Makefile
@@ -0,0 +1,37 @@
+# Makefile for Linux DVB API Version 3 test programs
+
+CC = gcc
+CFLAGS = -g -O2 -W -Wall -I../include
+
+TARGETS = \
+ diseqc \
+ set22k \
+ sendburst \
+ setvoltage \
+ setpid \
+ video \
+ test_sections \
+ test_sec_ne \
+ test_pes \
+ test_dvr \
+ test_dvr_play \
+ test_tt \
+ test_av \
+ test_av_play \
+ test_vevent \
+ test_stc \
+ test_stillimage
+
+# test \
+# test_audio \
+# test_front \
+# test_switch \
+# test_video \
+
+all: $(TARGETS)
+
+test_sections test_sec_ne test_pes test_tt: hex_dump.o
+
+clean:
+ rm -f $(TARGETS) *.o
+