aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libesg/transport/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lib/libesg/transport/Makefile')
-rw-r--r--lib/libesg/transport/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/lib/libesg/transport/Makefile b/lib/libesg/transport/Makefile
new file mode 100644
index 0000000..7900770
--- /dev/null
+++ b/lib/libesg/transport/Makefile
@@ -0,0 +1,22 @@
+# Makefile for linuxtv.org dvb-apps/lib/libesg/transport
+
+.PHONY: sub-error-transport
+
+sub-error-transport:
+ $(error You can't use this makefile directly.)
+
+ifneq ($(lib_name),)
+
+objects += transport/session_partition_declaration.o
+
+sub-install += transport
+
+else
+
+includes = session_partition_declaration.h
+
+include ../../../Make.rules
+
+lib_name = libesg/transport
+
+endif