aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules82
1 files changed, 16 insertions, 66 deletions
diff --git a/debian/rules b/debian/rules
index ad2290c..65fc6cc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,72 +1,22 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 by Joey Hess.
-#
-# This version is for a hypothetical package that builds an
-# architecture-dependant package, as well as an architecture-independent
-# package.
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/rules/dpatch.mk
+include /usr/share/cdbs/1/class/makefile.mk
-# include dpatch stuff
-include /usr/share/dpatch/dpatch.make
+DEB_MAKE_BUILD_TARGET := util
+DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/dvb-apps/
-SHELL=/bin/bash
+common-build-arch::
+ $(MAKE)
-build: build-stamp
-build-stamp: patch-stamp
- dh_testdir
- # Add here commands to compile the package.
- make
+clean::
+ [ ! -f Makefile ] || make clean
- touch build-stamp
-
-clean: clean1 unpatch
-
-clean1:
- dh_testdir
- dh_testroot
-
- rm -f *-stamp
-
- # Add here commands to clean up after the build process.
- -make clean
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # install stuff into debian/dvb-utils.
- cp -a util/av7110_loadkeys/README debian/dvb-utils/usr/share/doc/dvb-utils/README.av7110_loadkeys
- cp -a util/scan/README debian/dvb-utils/usr/share/doc/dvb-utils/README.scan
- cp -a util/szap/README debian/dvb-utils/usr/share/doc/dvb-utils/README.szap
-
- dh_install
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir -a
- dh_testroot -a
- dh_installdocs -a
- dh_installexamples -a
- dh_installmenu -a
- dh_installcron -a
- dh_installinfo -a
- dh_installchangelogs -a
- dh_strip -a
- dh_link -a
- dh_compress -a
- dh_fixperms -a
- dh_installdeb -a
- dh_shlibdeps -a
- dh_gencontrol -a
- dh_md5sums -a
- dh_builddeb -a
-
-binary: binary-arch
-.PHONY: build clean binary-arch binary build install patch unpatch configure clean1
+binary-install/dvb-apps::
+ # install READMEs into doc/dvb-apps
+ cp -a util/av7110_loadkeys/README debian/dvb-apps/usr/share/doc/dvb-apps/README.av7110_loadkeys
+ cp -a util/scan/README debian/dvb-apps/usr/share/doc/dvb-apps/README.scan
+ cp -a util/szap/README debian/dvb-apps/usr/share/doc/dvb-apps/README.szap
+ cp -a util/scan/dvb-h/README debian/dvb-apps/usr/share/doc/dvb-apps/README.dvb-h
+ cp -a util/ttusb_dec_reset/README debian/dvb-apps/usr/share/doc/dvb-apps/README.ttusb_dec_reset