aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules75
1 files changed, 75 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8c68ccb
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,75 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 by Joey Hess.
+#
+# This version is for a hypothetical package that builds an
+# architecture-dependant package, as well as an architecture-independent
+# package.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This is the debhelper compatability version to use.
+export DH_COMPAT=4
+
+# include dpatch stuff
+include /usr/share/dpatch/dpatch.make
+
+SHELL=/bin/bash
+
+build: build-stamp
+build-stamp: patch-stamp
+ dh_testdir
+ # Add here commands to compile the package.
+ make
+
+ touch build-stamp
+
+clean: clean1 unpatch
+
+clean1:
+ dh_testdir
+ dh_testroot
+
+ rm -f *-stamp
+
+ # Add here commands to clean up after the build process.
+ make clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # install stuff into debian/dvb-utils.
+ cp -a util/av7110_loadkeys/README debian/dvb-utils/usr/share/doc/dvb-utils/README.av7110_loadkeys
+ cp -a util/scan/README debian/dvb-utils/usr/share/doc/dvb-utils/README.scan
+ cp -a util/szap/README debian/dvb-utils/usr/share/doc/dvb-utils/README.szap
+
+ dh_install
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir -a
+ dh_testroot -a
+ dh_installdocs -a
+ dh_installexamples -a
+ dh_installmenu -a
+ dh_installcron -a
+ dh_installinfo -a
+ dh_installchangelogs -a
+ dh_strip -a
+ dh_link -a
+ dh_compress -a
+ dh_fixperms -a
+ dh_installdeb -a
+ dh_shlibdeps -a
+ dh_gencontrol -a
+ dh_md5sums -a
+ dh_builddeb -a
+
+binary: binary-arch
+.PHONY: build clean binary-arch binary build install patch unpatch configure clean1