aboutsummaryrefslogtreecommitdiffstats
path: root/test/libdvbsec
diff options
context:
space:
mode:
authoretobi <git@e-tobi.net>2013-09-03 09:48:41 +0200
committeretobi <git@e-tobi.net>2013-09-03 09:48:41 +0200
commitab959d7b4194715870128e616b8e29d4a101e488 (patch)
tree61a746231d30817be73416a7d67763fd677a1042 /test/libdvbsec
parent6b350466c4902c5b137e0efaf1d189128a7f18f5 (diff)
downloadlinux-dvb-apps-ab959d7b4194715870128e616b8e29d4a101e488.tar.gz
Imported Upstream version 1.1.1+rev1207upstream/1.1.1+rev1207
Diffstat (limited to 'test/libdvbsec')
-rw-r--r--test/libdvbsec/Makefile12
-rw-r--r--test/libdvbsec/dvbsec_test.c85
-rw-r--r--test/libdvbsec/test_sec.txt28
3 files changed, 125 insertions, 0 deletions
diff --git a/test/libdvbsec/Makefile b/test/libdvbsec/Makefile
new file mode 100644
index 0000000..27c9c21
--- /dev/null
+++ b/test/libdvbsec/Makefile
@@ -0,0 +1,12 @@
+# Makefile for linuxtv.org dvb-apps/test/libdvbsec
+
+binaries = dvbsec_test
+
+CPPFLAGS += -I../../lib
+LDLIBS += ../../lib/libdvbsec/libdvbsec.a
+
+.PHONY: all
+
+all: $(binaries)
+
+include ../../Make.rules
diff --git a/test/libdvbsec/dvbsec_test.c b/test/libdvbsec/dvbsec_test.c
new file mode 100644
index 0000000..b49d703
--- /dev/null
+++ b/test/libdvbsec/dvbsec_test.c
@@ -0,0 +1,85 @@
+/**
+ * dvbsec testing.
+ *
+ * Copyright (c) 2005 by Andrew de Quincey <adq_dvb@lidskialf.net>
+ *
+ * This library is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU Lesser General Public License as
+ * published by the Free Software Foundation; either version 2.1 of
+ * the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
+#include <stdlib.h>
+#include <stdio.h>
+#include <string.h>
+#include <libdvbsec/dvbsec_cfg.h>
+
+void syntax(void);
+
+struct dvbsec_config *secconfigs = NULL;
+int seccount = 0;
+
+int secload_callback(void *private, struct dvbsec_config *sec);
+
+int main(int argc, char *argv[])
+{
+ if (argc != 4) {
+ syntax();
+ }
+
+ if (!strcmp(argv[1], "-sec")) {
+
+ FILE *f = fopen(argv[2], "r");
+ if (!f) {
+ fprintf(stderr, "Unable to load %s\n", argv[2]);
+ exit(1);
+ }
+ dvbsec_cfg_load(f, NULL, secload_callback);
+ fclose(f);
+
+ f = fopen(argv[3], "w");
+ if (!f) {
+ fprintf(stderr, "Unable to write %s\n", argv[3]);
+ exit(1);
+ }
+ dvbsec_cfg_save(f, secconfigs, seccount);
+ fclose(f);
+
+ } else {
+ syntax();
+ }
+
+ exit(0);
+}
+
+int secload_callback(void *private, struct dvbsec_config *sec)
+{
+ (void) private;
+
+ struct dvbsec_config *tmp = realloc(secconfigs, (seccount+1) * sizeof(struct dvbsec_config));
+ if (tmp == NULL) {
+ fprintf(stderr, "Out of memory\n");
+ exit(1);
+ }
+ secconfigs = tmp;
+
+ memcpy(&secconfigs[seccount++], sec, sizeof(struct dvbsec_config));
+
+ return 0;
+}
+
+void syntax()
+{
+ fprintf(stderr,
+ "Syntax: dvbcfg_test <-zapchannel|-sec> <input filename> <output filename>\n");
+ exit(1);
+}
diff --git a/test/libdvbsec/test_sec.txt b/test/libdvbsec/test_sec.txt
new file mode 100644
index 0000000..1189026
--- /dev/null
+++ b/test/libdvbsec/test_sec.txt
@@ -0,0 +1,28 @@
+[sec]
+name=test1
+switch-frequency=100000
+lof-lo-v=20
+lof-lo-h=30
+lof-lo-l=40
+lof-lo-r=50
+lof-hi-v=60
+lof-hi-h=70
+lof-hi-l=80
+lof-hi-r=90
+config-type=none
+
+[sec]
+name=test2
+switch-frequency=200
+lof-lo-v=40
+lof-hi-h=50
+config-type=simple
+
+[sec]
+name=test3
+switch-frequency=100000
+lof-lo-l=20
+lof-hi-r=30
+config-type=advanced
+cmd-lo-v=MOOVH
+cmd-lo-h=MOOLH