aboutsummaryrefslogtreecommitdiffstats
path: root/lib
diff options
context:
space:
mode:
authoretobi <git@e-tobi.net>2013-09-03 09:48:44 +0200
committeretobi <git@e-tobi.net>2013-09-03 09:48:44 +0200
commit9a5228e0f2b898367b7943d294be58caf6ce8bb3 (patch)
tree8145575f8f67c126b81e607d47613f34add97393 /lib
parentab959d7b4194715870128e616b8e29d4a101e488 (diff)
downloadlinux-dvb-apps-9a5228e0f2b898367b7943d294be58caf6ce8bb3.tar.gz
Imported Upstream version 1.1.1+rev1273upstream/1.1.1+rev1273
Diffstat (limited to 'lib')
-rw-r--r--lib/libucsi/dvb/Makefile2
-rw-r--r--lib/libucsi/dvb/descriptor.h1
-rw-r--r--lib/libucsi/dvb/mpe_fec_section.h73
-rw-r--r--lib/libucsi/dvb/section.h1
-rw-r--r--lib/libucsi/dvb/time_slice_fec_identifier_descriptor.h94
-rw-r--r--lib/libucsi/mpeg/Makefile1
-rw-r--r--lib/libucsi/mpeg/datagram_section.h81
-rw-r--r--lib/libucsi/mpeg/section.h2
8 files changed, 255 insertions, 0 deletions
diff --git a/lib/libucsi/dvb/Makefile b/lib/libucsi/dvb/Makefile
index 78876dc..6f36e11 100644
--- a/lib/libucsi/dvb/Makefile
+++ b/lib/libucsi/dvb/Makefile
@@ -61,6 +61,7 @@ includes = ac3_descriptor.h \
local_time_offset_descriptor.h \
mhp_data_broadcast_id_descriptor.h \
mosaic_descriptor.h \
+ mpe_fec_section.h \
multilingual_bouquet_name_descriptor.h \
multilingual_component_descriptor.h \
multilingual_network_name_descriptor.h \
@@ -106,6 +107,7 @@ includes = ac3_descriptor.h \
terrestrial_delivery_descriptor.h \
time_shifted_event_descriptor.h \
time_shifted_service_descriptor.h \
+ time_slice_fec_identifier_descriptor.h \
tot_section.h \
transport_stream_descriptor.h \
tva_container_section.h \
diff --git a/lib/libucsi/dvb/descriptor.h b/lib/libucsi/dvb/descriptor.h
index 303e17a..345f6f0 100644
--- a/lib/libucsi/dvb/descriptor.h
+++ b/lib/libucsi/dvb/descriptor.h
@@ -88,6 +88,7 @@ extern "C"
#include <libucsi/dvb/terrestrial_delivery_descriptor.h>
#include <libucsi/dvb/time_shifted_event_descriptor.h>
#include <libucsi/dvb/time_shifted_service_descriptor.h>
+#include <libucsi/dvb/time_slice_fec_identifier_descriptor.h>
#include <libucsi/dvb/transport_stream_descriptor.h>
#include <libucsi/dvb/tva_id_descriptor.h>
#include <libucsi/dvb/vbi_data_descriptor.h>
diff --git a/lib/libucsi/dvb/mpe_fec_section.h b/lib/libucsi/dvb/mpe_fec_section.h
new file mode 100644
index 0000000..6db0a47
--- /dev/null
+++ b/lib/libucsi/dvb/mpe_fec_section.h
@@ -0,0 +1,73 @@
+/*
+ * section and descriptor parser
+ *
+ * Copyright (C) 2005 Kenneth Aafloy (kenneth@linuxtv.org)
+ * Copyright (C) 2005 Andrew de Quincey (adq_dvb@lidskialf.net)
+ * Copyright (C) 2008 Patrick Boettcher (pb@linuxtv.org)
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+ */
+
+#ifndef _UCSI_DVB_MPE_FEC_SECTION_H
+#define _UCSI_DVB_MPE_FEC_SECTION_H 1
+
+#ifdef __cplusplus
+extern "C"
+{
+#endif
+
+#include <libucsi/mpeg/section.h>
+
+/**
+ * mpe_fec_section structure. TODO
+ */
+struct mpe_fec_section {
+ struct section head;
+};
+
+
+/**
+ * real_time_paramters
+ * can also be found in datagram_section in MAC4-1-bytes */
+struct real_time_parameters {
+ EBIT4(uint32_t delta_t : 12; ,
+ uint32_t table_boundary : 1; ,
+ uint32_t frame_boundary : 1; ,
+ uint32_t address : 18; )
+};
+
+
+static inline struct real_time_parameters * datagram_section_real_time_parameters_codec(struct datagram_section *d)
+{
+ struct real_time_parameters *rt = (struct real_time_parameters *) &d->MAC_address_4;
+ uint8_t b[4];
+ b[0] = d->MAC_address_4;
+ b[1] = d->MAC_address_3;
+ b[2] = d->MAC_address_2;
+ b[3] = d->MAC_address_1;
+
+ rt->delta_t = (b[0] << 4) | ((b[1] >> 4) & 0x0f);
+ rt->table_boundary = (b[1] >> 3) & 0x1;
+ rt->frame_boundary = (b[1] >> 2) & 0x1;
+ rt->address = ((b[1] & 0x3) << 16) | (b[2] << 8) | b[3];
+
+ return rt;
+}
+
+#ifdef __cplusplus
+}
+#endif
+
+#endif
diff --git a/lib/libucsi/dvb/section.h b/lib/libucsi/dvb/section.h
index 8488d71..70e0880 100644
--- a/lib/libucsi/dvb/section.h
+++ b/lib/libucsi/dvb/section.h
@@ -39,6 +39,7 @@ extern "C"
#include <libucsi/dvb/tot_section.h>
#include <libucsi/dvb/tva_container_section.h>
#include <libucsi/dvb/int_section.h>
+#include <libucsi/dvb/mpe_fec_section.h>
/**
* The following are not implemented just now.
diff --git a/lib/libucsi/dvb/time_slice_fec_identifier_descriptor.h b/lib/libucsi/dvb/time_slice_fec_identifier_descriptor.h
new file mode 100644
index 0000000..00f3048
--- /dev/null
+++ b/lib/libucsi/dvb/time_slice_fec_identifier_descriptor.h
@@ -0,0 +1,94 @@
+/*
+ * section and descriptor parser
+ *
+ * Copyright (C) 2005 Kenneth Aafloy (kenneth@linuxtv.org)
+ * Copyright (C) 2005 Andrew de Quincey (adq_dvb@lidskialf.net)
+ * Copyright (C) 2008 Patrick Boettcher (pb@linuxtv.org)
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+ */
+
+#ifndef _UCSI_DVB_TIME_SLICE_FEC_IDENTIFIER_DESCRIPTOR
+#define _UCSI_DVB_TIME_SLICE_FEC_IDENTIFIER_DESCRIPTOR 1
+
+#ifdef __cplusplus
+extern "C"
+{
+#endif
+
+#include <libucsi/descriptor.h>
+#include <libucsi/types.h>
+
+/*
+ * dvb_time_slice_fec_identifier_descriptor structure.
+ */
+struct dvb_time_slice_fec_identifier_descriptor {
+ struct descriptor d;
+
+ EBIT4(uint8_t time_slicing :1; ,
+ uint8_t mpe_fec :2; ,
+ uint8_t reserved :2; ,
+ uint8_t frame_size :3; );
+
+ uint8_t max_burst_duration;
+
+ EBIT2(uint8_t max_average_rate :4; ,
+ uint8_t time_slice_fec_id :4; );
+ /* id_selector_bytes[] */
+};
+
+static inline struct dvb_time_slice_fec_identifier_descriptor *
+ dvb_time_slice_fec_identifier_descriptor_codec(struct descriptor* d)
+{
+ if (d->len < 3)
+ return NULL;
+ return (struct dvb_time_slice_fec_identifier_descriptor *) d;
+}
+
+static inline uint8_t dvb_time_slice_fec_identifier_selector_byte_length(struct dvb_time_slice_fec_identifier_descriptor *d)
+{
+ return d->d.len - 3;
+}
+
+static inline uint8_t * dvb_time_slice_fec_identifier_selector_bytes(struct dvb_time_slice_fec_identifier_descriptor *d)
+{
+ if (d->d.len < 3)
+ return NULL;
+ else
+ return ((uint8_t *) d) + 2 + 3;
+}
+
+static inline uint16_t dvb_time_slice_fec_identifier_max_burst_duration_msec(struct dvb_time_slice_fec_identifier_descriptor *d)
+{
+ return (d->max_burst_duration + 1) * 20;
+}
+
+static inline uint16_t dvb_time_slice_fec_identifier_frame_size_kbits(struct dvb_time_slice_fec_identifier_descriptor *d)
+{
+ if (d->frame_size > 3)
+ return 0;
+ return (d->frame_size+1) * 512;
+}
+
+static inline uint16_t dvb_time_slice_fec_identifier_frame_size_rows(struct dvb_time_slice_fec_identifier_descriptor *d)
+{
+ return dvb_time_slice_fec_identifier_frame_size_kbits(d) / 2;
+}
+
+#ifdef __cplusplus
+}
+#endif
+
+#endif
diff --git a/lib/libucsi/mpeg/Makefile b/lib/libucsi/mpeg/Makefile
index ace8808..43bc91d 100644
--- a/lib/libucsi/mpeg/Makefile
+++ b/lib/libucsi/mpeg/Makefile
@@ -24,6 +24,7 @@ includes = audio_stream_descriptor.h \
content_labelling_descriptor.h \
copyright_descriptor.h \
data_stream_alignment_descriptor.h \
+ datagram_section.h \
descriptor.h \
external_es_id_descriptor.h \
fmc_descriptor.h \
diff --git a/lib/libucsi/mpeg/datagram_section.h b/lib/libucsi/mpeg/datagram_section.h
new file mode 100644
index 0000000..769773a
--- /dev/null
+++ b/lib/libucsi/mpeg/datagram_section.h
@@ -0,0 +1,81 @@
+/*
+ * section and descriptor parser
+ *
+ * Copyright (C) 2005 Kenneth Aafloy (kenneth@linuxtv.org)
+ * Copyright (C) 2005 Andrew de Quincey (adq_dvb@lidskialf.net)
+ * Copyright (C) 2008 Patrick Boettcher (pb@linuxtv.org)
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+ */
+
+#ifndef _UCSI_MPEG_DATAGRAM_SECTION_H
+#define _UCSI_MPEG_DATAGRAM_SECTION_H 1
+
+#ifdef __cplusplus
+extern "C"
+{
+#endif
+
+#include <libucsi/section.h>
+
+/**
+ * datagram_section structure.
+ */
+struct datagram_section {
+ struct section head;
+
+ uint8_t MAC_address_6;
+ uint8_t MAC_address_5;
+ EBIT5(uint8_t reserved : 2; ,
+ uint8_t payload_scrambling_control : 2; ,
+ uint8_t address_scrambling_control : 2; ,
+ uint8_t LLC_SNAP_flag : 1; ,
+ uint8_t current_next_indicator : 1; );
+ uint8_t section_number;
+ uint8_t last_section_number;
+ uint8_t MAC_address_4;
+ uint8_t MAC_address_3;
+ uint8_t MAC_address_2;
+ uint8_t MAC_address_1;
+
+ /* LLC_SNAP or IP-data */
+ /* if last section stuffing */
+ /* CRC */
+} __ucsi_packed;
+
+/**
+ */
+static inline struct datagram_section *datagram_section_codec(struct section *section)
+{
+ /* something to do here ? */
+ return (struct datagram_section *) section;
+}
+
+static inline uint8_t *datagram_section_ip_data(struct datagram_section *d)
+{
+ return (uint8_t *) d + sizeof(struct section) + 2 + 1 + 1 + 1 + 4;
+}
+
+static inline size_t datagram_section_ip_data_length(struct datagram_section *d)
+{
+ return section_length(&d->head) - (sizeof(struct section) + 2 + 1 + 1 + 1 + 4) - CRC_SIZE;
+}
+
+
+#ifdef __cplusplus
+}
+#endif
+
+#endif
diff --git a/lib/libucsi/mpeg/section.h b/lib/libucsi/mpeg/section.h
index 7dbff93..f71f95e 100644
--- a/lib/libucsi/mpeg/section.h
+++ b/lib/libucsi/mpeg/section.h
@@ -33,6 +33,7 @@ extern "C"
#include <libucsi/mpeg/pmt_section.h>
#include <libucsi/mpeg/tsdt_section.h>
#include <libucsi/mpeg/metadata_section.h>
+#include <libucsi/mpeg/datagram_section.h>
#define TRANSPORT_PAT_PID 0x00
#define TRANSPORT_CAT_PID 0x01
@@ -49,6 +50,7 @@ enum mpeg_section_tag {
stag_mpeg_iso14496_scene_description = 0x04,
stag_mpeg_iso14496_object_description = 0x05,
stag_mpeg_metadata = 0x06,
+ stag_mpeg_datagram = 0x3e,
};
#ifdef __cplusplus