aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libucsi/mpeg/Makefile
diff options
context:
space:
mode:
authorMark Purcell <msp@debian.org>2008-06-22 11:00:40 +1000
committeretobi <git@e-tobi.net>2013-09-03 09:48:42 +0200
commit891c51ff368ed700dec6025eeb47ce4d96f76418 (patch)
tree3729664829e4faa691d403274f38eb10890b533c /lib/libucsi/mpeg/Makefile
parent1c6e1f28f54ec2606c23936c1d8689f2be55a86c (diff)
parentab959d7b4194715870128e616b8e29d4a101e488 (diff)
downloadlinux-dvb-apps-891c51ff368ed700dec6025eeb47ce4d96f76418.tar.gz
Imported Debian patch 1.1.1+rev1207-1debian/1.1.1+rev1207-1
Diffstat (limited to 'lib/libucsi/mpeg/Makefile')
-rw-r--r--lib/libucsi/mpeg/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/lib/libucsi/mpeg/Makefile b/lib/libucsi/mpeg/Makefile
new file mode 100644
index 0000000..ace8808
--- /dev/null
+++ b/lib/libucsi/mpeg/Makefile
@@ -0,0 +1,65 @@
+# Makefile for linuxtv.org dvb-apps/lib/libucsi/mpeg
+
+.PHONY: sub-error-mpeg
+
+sub-error-mpeg:
+ $(error You can't use this makefile directly.)
+
+ifneq ($(lib_name),)
+
+objects += mpeg/cat_section.o \
+ mpeg/metadata_section.o \
+ mpeg/odsmt_section.o \
+ mpeg/pat_section.o \
+ mpeg/pmt_section.o \
+ mpeg/tsdt_section.o
+
+sub-install += mpeg
+
+else
+
+includes = audio_stream_descriptor.h \
+ ca_descriptor.h \
+ cat_section.h \
+ content_labelling_descriptor.h \
+ copyright_descriptor.h \
+ data_stream_alignment_descriptor.h \
+ descriptor.h \
+ external_es_id_descriptor.h \
+ fmc_descriptor.h \
+ fmxbuffer_size_descriptor.h \
+ hierarchy_descriptor.h \
+ ibp_descriptor.h \
+ iod_descriptor.h \
+ iso_639_language_descriptor.h \
+ maximum_bitrate_descriptor.h \
+ metadata_descriptor.h \
+ metadata_pointer_descriptor.h \
+ metadata_section.h \
+ metadata_std_descriptor.h \
+ mpeg4_audio_descriptor.h \
+ mpeg4_video_descriptor.h \
+ multiplex_buffer_descriptor.h \
+ multiplex_buffer_utilization_descriptor.h \
+ muxcode_descriptor.h \
+ odsmt_section.h \
+ pat_section.h \
+ pmt_section.h \
+ private_data_indicator_descriptor.h \
+ registration_descriptor.h \
+ section.h \
+ sl_descriptor.h \
+ smoothing_buffer_descriptor.h \
+ std_descriptor.h \
+ system_clock_descriptor.h \
+ target_background_grid_descriptor.h \
+ tsdt_section.h \
+ types.h \
+ video_stream_descriptor.h \
+ video_window_descriptor.h
+
+include ../../../Make.rules
+
+lib_name = libucsi/mpeg
+
+endif