aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authoretobi <git@e-tobi.net>2013-09-03 09:48:52 +0200
committeretobi <git@e-tobi.net>2013-09-03 09:48:52 +0200
commit5501530a778ad588a8ccd3f1584ea58f74c0cec9 (patch)
tree125c0eb7951f4b97c6b2be809332dcbe3633083c /Makefile
parent76c08672bc6c2984ebd7045a71862099890c9118 (diff)
downloadlinux-dvb-apps-5501530a778ad588a8ccd3f1584ea58f74c0cec9.tar.gz
Imported Upstream version 1.1.1+rev1483upstream/1.1.1+rev1483
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 0ca84b0..65a2273 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,11 @@
# Makefile for linuxtv.org dvb-apps
+# get DVB API version
+VERSION_FILE := "/usr/include/linux/dvb/version.h"
+
+DVB_API_MAJOR := $(word 3, $(shell grep -m1 "DVB_API_VERSION" $(VERSION_FILE)) )
+DVB_API_MINOR := $(word 3, $(shell grep -m1 "DVB_API_VERSION_MINOR" $(VERSION_FILE)) )
+
.PHONY: all clean install update
all clean install: