aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoretobi <git@e-tobi.net>2013-09-19 22:37:28 +0200
committeretobi <git@e-tobi.net>2013-09-19 23:09:18 +0200
commit7e94371834c8cb1f719f0fdcd2195b9cf1557927 (patch)
treeba7c1cb79e5d97b870852301d9594715bb0c73d0
parentea0ef4226da7b2a5bb9e5496d25acac2c69025f9 (diff)
downloadlinux-dvb-apps-7e94371834c8cb1f719f0fdcd2195b9cf1557927.tar.gz
Use debhelper 9 to make the hardening options from dpkg-buildflags being used
-rw-r--r--debian/changelog2
-rw-r--r--debian/compat2
-rw-r--r--debian/control2
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/use-ldflags.patch50
5 files changed, 55 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index e6ffe65..b0d110d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,8 @@ linuxtv-dvb-apps (1.1.1+rev1500-1) UNRELEASED; urgency=low
* d/control: Build-depend on linux-libc-dev (>= 3.3) because the DVB API 5.5
is required
* d/control: Standards-Version: 3.9.4
+ * Use debhelper 9 to make the hardening options from dpkg-buildflags being
+ used
-- Jonathan McCrohan <jmccrohan@gmail.com> Tue, 17 Sep 2013 00:39:18 +0100
diff --git a/debian/compat b/debian/compat
index 45a4fb7..ec63514 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-8
+9
diff --git a/debian/control b/debian/control
index cb9ef8c..35d4b60 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: extra
Maintainer: Debian VDR Team <pkg-vdr-dvb-devel@lists.alioth.debian.org>
Uploaders: Mark Purcell <msp@debian.org>, Tobias Grimm <etobi@debian.org>,
Jonathan McCrohan <jmccrohan@gmail.com>
-Build-Depends: debhelper (>= 8), libx11-dev, libzvbi-dev, linux-libc-dev (>= 3.3)
+Build-Depends: debhelper (>= 9), libx11-dev, libzvbi-dev, linux-libc-dev (>= 3.3)
Standards-Version: 3.9.4
Vcs-Git: git://anonscm.debian.org/pkg-vdr-dvb/linuxtv-dvb-apps.git
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-vdr-dvb/linuxtv-dvb-apps.git
diff --git a/debian/patches/series b/debian/patches/series
index b1ba85c..37b732b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -6,3 +6,4 @@ uk-CrystalPalace.diff
apps_manpages.patch
alevt.patch
dbug606728.diff
+use-ldflags.patch
diff --git a/debian/patches/use-ldflags.patch b/debian/patches/use-ldflags.patch
new file mode 100644
index 0000000..f929027
--- /dev/null
+++ b/debian/patches/use-ldflags.patch
@@ -0,0 +1,50 @@
+Description: Use LDFLAGS passed in from dpkg-buildflags
+ The alevt and lib binaries are not linked with the hardening options
+ provided by dpkg-buildflags because LDFLAGS isn't used there.
+ This patch simple adds the LDFLAGS to the Makefiles.
+Author: Tobias Grimm <etobi@debian.org>
+Date: Thu, 19 Sep 2013 23:04:58 +0200
+
+Index: linuxtv-dvb-apps/util/alevt/Makefile
+===================================================================
+--- linuxtv-dvb-apps.orig/util/alevt/Makefile 2013-09-19 23:00:31.000000000 +0200
++++ linuxtv-dvb-apps/util/alevt/Makefile 2013-09-19 23:00:34.000000000 +0200
+@@ -25,13 +25,13 @@
+ all: alevt alevt-date alevt-cap alevt.1 alevt-date.1 alevt-cap.1
+
+ alevt: $(OBJS)
+- $(CC) $(OPT) $(OBJS) -o alevt -L$(PREFIX)/lib -L$(PREFIX)/lib64 -lX11 $(EXPLIBS)
++ $(CC) $(OPT) $(OBJS) $(LDFLAGS) -o alevt -L$(PREFIX)/lib -L$(PREFIX)/lib64 -lX11 $(EXPLIBS)
+
+ alevt-date: $(TOBJS)
+- $(CC) $(OPT) $(TOBJS) -o alevt-date $(ZVBILIB)
++ $(CC) $(OPT) $(TOBJS) $(LDFLAGS) -o alevt-date $(ZVBILIB)
+
+ alevt-cap: $(COBJS)
+- $(CC) $(OPT) $(COBJS) -o alevt-cap $(EXPLIBS)
++ $(CC) $(OPT) $(COBJS) $(LDFLAGS) -o alevt-cap $(EXPLIBS)
+
+ font.o: font1.xbm font2.xbm font3.xbm font4.xbm
+ fontsize.h: font1.xbm font2.xbm font3.xbm font4.xbm
+Index: linuxtv-dvb-apps/Make.rules
+===================================================================
+--- linuxtv-dvb-apps.orig/Make.rules 2013-09-19 23:00:29.000000000 +0200
++++ linuxtv-dvb-apps/Make.rules 2013-09-19 23:00:34.000000000 +0200
+@@ -47,7 +47,7 @@
+ %: %.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) -MMD $(LDFLAGS) -o $@ $< $(filter-out %.h %.c,$^) $(LOADLIBES) $(LDLIBS)
+ %.so:
+- $(CC) -shared -o $@ $^
++ $(CC) -shared $(LDFLAGS) -o $@ $^
+ %.a:
+ $(AR) rcs $@ $^
+ clean::
+@@ -82,7 +82,7 @@
+ @$(CC) $(CPPFLAGS) $(CFLAGS) -MMD $(LDFLAGS) -o $@ $< $(filter-out %.h %.c,$^) $(LOADLIBES) $(LDLIBS)
+ %.so:
+ @echo CC $@
+- @$(CC) -shared -o $@ $^
++ @$(CC) -shared $(LDFLAGS) -o $@ $^
+ %.a:
+ @echo AR $@
+ @$(AR) rcs $@ $^