aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..14d2fe9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+# export DH_VERBOSE=1
+
+override_dh_auto_build:
+ make
+ make phidget21.jar
+
+override_dh_strip:
+ dh_strip -p libphidget21-0 --dbg-package=libphidget21-dbg
+
+%:
+ dh $@ --with autoreconf --with autotools-dev